WHAT ! No RACE mode ? - Alfa Romeo Stelvio Forum
 1Likes
  • 1 Post By lost1750GTV
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 04-13-2019, 09:53 PM Thread Starter
Junior Member
 
chknparm's Avatar
 
Join Date: Apr 2019
Posts: 6
WHAT ! No RACE mode ?

I have a new 2018 Quadrifoglio. Have watched YouTube videos and even though the dealer saw fit not to give me a manual for my car, figured that I have to hold for 5 seconds on race before it enters the mode. Mine does nothing. I have tried with a warmed up engine, static drive, during driving, while dreaming in fluent Italian, etc. Nothing.

I have to take the car back for a recall on the ACC and will ask, but if anyone here can give me some guidance on what I am doing wrong or if this is a known flaw to fix - much appreciate your fix advise to ensure the tech does it properly. Thanks.
chknparm is offline  
post #2 of 9 (permalink) Old 04-14-2019, 05:27 AM
Senior Member
 
jwq2's Avatar
 
Join Date: Jul 2018
Location: The Hague, The Netherlands
Posts: 214
Garage
the downloadable manual is here :
2018-Alfa_Romeo-Stelvio_Quadrifoglio.pdf

My car : https://www.stelvioforum.com/forum/g...vehicle_id=559

previous Alfa's : Alfa alfetta GTV, Alfasud QV, Spider 2.0 Veloce, 164 2.0, 147 GTA, Alfa giulia AWD 280 Hp
jwq2 is online now  
post #3 of 9 (permalink) Old 04-14-2019, 07:51 AM
Senior Member
 
Knightofargh's Avatar
 
Join Date: Feb 2018
Location: United States, Cincinnati OH
Posts: 399
Garage
If it’s brand new Race won’t enable (supposedly, don’t know personally because I’m a filthy 2L peasant) until the computer decides the engine is broken in.

2018 Stelvio Ti Sport: Misano Blue with yellow calipers

Performance pack, leather dash, sunroof, CarPlay/AA, HK upgrade (-3 fade +7 bass -3 mid -4 treble)
Knightofargh is online now  
post #4 of 9 (permalink) Old 04-14-2019, 07:53 AM
Senior Member
 
Join Date: Aug 2017
Location: MAgical
Posts: 1,833
something like that ^
lost1750GTV is online now  
post #5 of 9 (permalink) Old 04-14-2019, 12:56 PM
Junior Member
 
Join Date: Dec 2018
Posts: 27
mine worked immediately. car cannot be off. engine has to be on (stop start not currently being used) turn nob all the way up. enjoy
JFerraro819 is offline  
post #6 of 9 (permalink) Old 04-14-2019, 01:02 PM
Senior Member
 
Join Date: Aug 2017
Location: MAgical
Posts: 1,833
Mine could engage, but it wasnt really "unleashed" immediately
Flunx likes this.
lost1750GTV is online now  
post #7 of 9 (permalink) Old 04-15-2019, 10:07 AM
Senior Member
 
Join Date: Sep 2018
Location: Chicago, IL
Posts: 173
And you definitely don't have to hold it for 5 seconds to get it to engage. Just turn it until you feel a positive stop then release it.
Jay-Ten is offline  
post #8 of 9 (permalink) Old 04-15-2019, 10:55 AM Thread Starter
Junior Member
 
chknparm's Avatar
 
Join Date: Apr 2019
Posts: 6
Thank you for the reply. 1300 miles. Figured it should at least engage, or give me a screen that the engine is too shy. The display just simply goes back to nav/radio, or whatever was previously selected. Found that strange.
chknparm is offline  
post #9 of 9 (permalink) Old 04-15-2019, 10:56 AM Thread Starter
Junior Member
 
chknparm's Avatar
 
Join Date: Apr 2019
Posts: 6
Many thanks.
chknparm is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Race mode exhaust coming to Dynamic mode this month LeoManiaX Stelvio Quadrifoglio Discussion 17 07-11-2019 01:58 AM
Race mode on - Done Marzio Stelvio Projects 34 06-18-2019 01:50 AM
ECO mode Neodoc Alfa Romeo Stelvio General Discussion Forum 3 12-17-2018 11:52 PM
My take on the "DNA" mode settings LC_LC Alfa Romeo Stelvio General Discussion Forum 23 06-27-2018 02:06 PM
Dynamic Mode, not terribly dynamic? Moholland Alfa Romeo Stelvio General Discussion Forum 21 05-03-2018 04:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome