Electronic throttle control warning - Alfa Romeo Stelvio Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 25 (permalink) Old 07-04-2018, 12:15 PM Thread Starter
Senior Member
 
LC_LC's Avatar
 
Join Date: Jan 2018
Location: Florida
Posts: 763
Electronic throttle control warning

I know this has been discussed here, did a search, but did not find it. This happened when giving throttle to merge with interstate traffic. Also, the auto start/stop not available warning came on as well, I think they go hand in hand. Hardly any power, but could reach traffic speed, it just takes a few. The warning was not flashing, on solid, per owners manual when solid the vehicle can still be driven to a dealer. I was not giving throttle and brake at the same time.

After getting home, I let it sit for about 30 minutes and started it up, no warnings shown. My question, for those that have this happen and it cleared after sitting for a few, is there anything I should be watching for on the next drive or two?

2018 Stelvio Ti Sport, Black/Red
LC_LC is offline  
post #2 of 25 (permalink) Old 07-05-2018, 12:07 PM Thread Starter
Senior Member
 
LC_LC's Avatar
 
Join Date: Jan 2018
Location: Florida
Posts: 763
Quote:
Originally Posted by LC_LC View Post
I know this has been discussed here, did a search, but did not find it. This happened when giving throttle to merge with interstate traffic. Also, the auto start/stop not available warning came on as well, I think they go hand in hand. Hardly any power, but could reach traffic speed, it just takes a few. The warning was not flashing, on solid, per owners manual when solid the vehicle can still be driven to a dealer. I was not giving throttle and brake at the same time.

After getting home, I let it sit for about 30 minutes and started it up, no warnings shown. My question, for those that have this happen and it cleared after sitting for a few, is there anything I should be watching for on the next drive or two?
It happened to me agin this morning, I got it to the dealer. They did not see any codes, but did an ECU update, Service Manager stated that should take care of it.

2018 Stelvio Ti Sport, Black/Red
LC_LC is offline  
post #3 of 25 (permalink) Old 07-09-2018, 12:18 PM
Senior Member
 
AlfaRomeoCares's Avatar
 
Join Date: Mar 2018
Location: Auburn Hills, MI
Posts: 136
Quote:
Originally Posted by LC_LC View Post
It happened to me agin this morning, I got it to the dealer. They did not see any codes, but did an ECU update, Service Manager stated that should take care of it.
Hi LC_LC,

Thank you for sharing this experience. At this time, has your concern been resolved? Please send us a PM if you are in need of additional assistance.

Darlene
Alfa Romeo Social Care Specialist
AlfaRomeoCares is online now  
post #4 of 25 (permalink) Old 07-09-2018, 01:46 PM Thread Starter
Senior Member
 
LC_LC's Avatar
 
Join Date: Jan 2018
Location: Florida
Posts: 763
Quote:
Originally Posted by AlfaRomeoCares View Post
Hi LC_LC,

Thank you for sharing this experience. At this time, has your concern been resolved? Please send us a PM if you are in need of additional assistance.

Darlene
Alfa Romeo Social Care Specialist
Thanks for the offer, has not happened after the dealer did the update.

2018 Stelvio Ti Sport, Black/Red
LC_LC is offline  
post #5 of 25 (permalink) Old 07-09-2018, 02:00 PM
Super Moderator
 
Marzio's Avatar
 
Join Date: Sep 2017
Location: Padua - Italy
Posts: 759
Garage
This issue is very strange

Italian Stelvio 280hp owner from Padua
Marzio is offline  
post #6 of 25 (permalink) Old 07-09-2018, 02:13 PM Thread Starter
Senior Member
 
LC_LC's Avatar
 
Join Date: Jan 2018
Location: Florida
Posts: 763
Quote:
Originally Posted by Marzio View Post
This issue is very strange
Seems so, but I am a bit off as is my Stelvio. I guess I and my Stelvio are a good match.

2018 Stelvio Ti Sport, Black/Red
LC_LC is offline  
post #7 of 25 (permalink) Old 07-12-2018, 04:58 PM
Senior Member
 
AlfaRomeoCares's Avatar
 
Join Date: Mar 2018
Location: Auburn Hills, MI
Posts: 136
Quote:
Originally Posted by LC_LC View Post
Thanks for the offer, has not happened after the dealer did the update.
Glad to hear it, LC_LC. Feel free to reach out to us at any time.

Darlene
Alfa Romeo Social Care Specialist
AlfaRomeoCares is online now  
post #8 of 25 (permalink) Old 07-29-2018, 11:40 PM
Junior Member
 
Join Date: Feb 2018
Location: Long Island, NY
Posts: 25
This has been happening to me already a few times, and no, it isn't due to giving throttle and brake at the same time... the car is in the shop since Wednesday night (today's Sunday) to check for codes, I can post here what turns up, if anything. I, however, think nothing will come of it, as it has already been looked at and nothing found the last time I brought the car into the shop (to get the recall work completed). We'll see... other than this issue the car has been great, I've got over 6k miles driven with it by now.
AlfaDream is online now  
post #9 of 25 (permalink) Old 08-18-2018, 03:47 PM
Junior Member
 
Join Date: Feb 2018
Location: Long Island, NY
Posts: 25
Since my last post my car spent 2.5 weeks at the dealer, with them attempting to figure out and fix this problem. I was told the car was ready to pick up and I did. Here we are, about a week later, and the message popped up again! This time while the car was just idling in Park.
After multiple attempts at fixing this problem by my dealer and Alfa, it seems this is just unfixable. Maybe something we all just have to live with? The car seems to reset itself after a number of hours (from my experience up to 24 may be required), so this is not a show stopper on the car, but it does make me wonder if I’d stick with Alfa once my lease expires. Anyone have a similar problem and had a proper explanation of the cause and the fix?
This has certainly gotten quite frustrating for me, particularly because Alfa and the service department seem helpless on this.
Attached Thumbnails
Click image for larger version

Name:	CA1B168B-03F4-4978-A214-6AC66E50ECF4_1534621617405.jpg
Views:	168
Size:	307.9 KB
ID:	11203   Click image for larger version

Name:	78F2E43B-1A9C-43DF-B429-1ECBA708FFB9_1534621635047.jpg
Views:	75
Size:	298.2 KB
ID:	11205  
AlfaDream is online now  
post #10 of 25 (permalink) Old 08-18-2018, 04:19 PM
Super Moderator
 
Scalewoodman's Avatar
 
Join Date: Nov 2017
Location: Lancaster, Pennsylvania USA
Posts: 1,435
So sorry to see this. Wouldn't work for me (I'm a little a.r. about these kinds of things). There has to be a reason or trade into another one (last resort for them). Rooting for you to get back to enjoyment and carefree driving as it should be.

2018 Stelvio - Vulcano, Chocolate interior - 20" wheels + Yellow calipers / safety pkgs - Build: July 2017 - Godetevi la corsa!
Scalewoodman is online now  
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronic Throttle Message (129 miles on odometer) Neeemo Stelvio Complaints, Issues And Problems 13 07-17-2018 05:41 PM
Service Electronic Throttle Message ARS Stelvio Complaints, Issues And Problems 20 05-31-2018 10:34 PM
This just happened: Service Elec Throttle Control AlfaDream Stelvio Complaints, Issues And Problems 5 05-19-2018 12:35 PM
Can't Cope Crazy Cruise Control InkPump Stelvio Complaints, Issues And Problems 5 02-10-2018 07:18 PM
Misleading US reviews about Hill Descent Control rossocompetizione Engine and Technical Discussion 4 12-06-2017 08:36 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome