Chirping? - Page 2 - Alfa Romeo Stelvio Forum
 2Likes
Reply
 
LinkBack Thread Tools
post #11 of 19 (permalink) Old 03-23-2018, 09:59 AM
Super Moderator
 
Join Date: Sep 2017
Posts: 398
Quote:
Originally Posted by Cambir View Post
... Then Alfa assigned a rep to my "case" who continued to follow up with me via email and phone on the delivery of the part.
I was told by my service manager that this is supposed happen for almost every service issue on the 2018's (not sure if does/doesn't also apply to the 2017's), the dealer is supposed to be reporting the case to Alfa where they are supposed to do a phone follow-up to get customer feedback.

2018 Stelvio Ti Sport, Rosso Alfa Red, Black sport seats & interior, sun roof, HK audio system
SailDrive is offline  
post #12 of 19 (permalink) Old 03-23-2018, 10:16 AM
Junior Member
 
vallansa's Avatar
 
Join Date: Mar 2018
Location: Spain
Posts: 11
Mine was made in July 2017. Do you know if you have to disassemble many parts of the car to change the fan?

STELVIO 2.0 280CV FIRST EDITION I AT8 AWD GRIS STROMBOLI
vallansa is offline  
post #13 of 19 (permalink) Old 03-29-2018, 01:50 AM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 17
Quote:
Originally Posted by vallansa View Post
Mine was made in July 2017. Do you know if you have to disassemble many parts of the car to change the fan?
Not sure...I've now been pushed out another week for my replacement. Will update once complete.
Cambir is offline  
post #14 of 19 (permalink) Old 04-06-2018, 11:49 AM
Junior Member
 
Join Date: Mar 2018
Posts: 4
Garage
Lightbulb blower motor replaced

I was at the dealership yesterday and got the BLOWER MOTOR replaced on our Stelvio. The ride home is our only reference point but it was a positive first ride with no chirping. We will continue to monitor and advise the service team either way once we have logged more rides since the issue we were experiencing was intermittent and we want to ensure that it is 100% resolved. The chirping also did not start immediately when we purchased the vehicle in August2017. It started in the Fall months after 3K miles and when it got colder out.

For now though, we think we may have success. Make sure you have your dealer submit a case for you and press until you get supported. Good luck!
Scalewoodman and oyeahhhhhh like this.
carsnob is offline  
post #15 of 19 (permalink) Old 04-06-2018, 02:26 PM
Member
 
Join Date: Mar 2018
Location: Bergen County, New Jersey
Posts: 30
Initially, I thought the chirping was coming from my sunroof on the right side (and i have a post about that). It was only till I coincidentally turned off the air circulation while hearing it that I realized it was actually connected to that - for me anyway. So now, I just keep it off most of the time. I only notice it when I'm travelling over 75 MPH (which is my usual speed but...). If I turn it on at that speed, I hear the chirping / whistling. Once off, its gone.
joelmac is online now  
post #16 of 19 (permalink) Old 04-06-2018, 10:26 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 17
Just got the car back today with blower motor replaced. Good so far, but outside temp is far too high to reproduce the sound. Will also monitor and hope it's gone for good!
Cambir is offline  
post #17 of 19 (permalink) Old 02-16-2019, 04:03 PM
Junior Member
 
Join Date: Nov 2018
Location: Chicago
Posts: 18
The chirping on my '18 Quad is driving me nuts and also believe it is blower motor. Is the issue solved for those who have had these replaced?

2018 Alfa Romeo Stelvio Quadrifoglio (Rosso Competizione/Yellow calipers)
2013 Land Rover LR4
chialfazagato is offline  
post #18 of 19 (permalink) Old 03-28-2019, 07:31 PM
Junior Member
 
J-s Roopnarain's Avatar
 
Join Date: Mar 2019
Posts: 2
i have the same problem with my ti sport also. i might need to contact the dealer.
i only had the car for 2 months. would this be cover under warranty?
J-s Roopnarain is offline  
post #19 of 19 (permalink) Old 03-28-2019, 11:18 PM
Senior Member
 
Join Date: Jan 2019
Location: Buffalo NY
Posts: 101
Quote:
Originally Posted by vallansa View Post
It happens to me too. Here you can see it in a video. If you realize when I turn off the fan the sound goes off little by little so it sure is the fan. I have 8,500 km In the review of the 15,000 I will notify the dealer to fix it or change it.

Aqu: https://youtu.be/-GEEZZi3qXM
I hear road noise ,not chirping.
Alfabreath is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome