Adding powered sub to base system:) - Page 4 - Alfa Romeo Stelvio Forum
 13Likes
Reply
 
LinkBack Thread Tools
post #31 of 41 (permalink) Old 07-01-2019, 03:42 PM
Senior Member
 
ALFAOFFROAD's Avatar
 
Join Date: Jul 2018
Posts: 1,110
What is the problem getting the sub signal?

2018 Stelvio 2.0T AWD

Opinions on Automobiles
https://www.youtube.com/channel/UCPc...CMdK6vlFLuSWLQ
ALFAOFFROAD is online now  
post #32 of 41 (permalink) Old 07-01-2019, 04:43 PM
Member
 
Scottlarson737's Avatar
 
Join Date: May 2019
Posts: 62
Quote:
Originally Posted by ALFAOFFROAD View Post
What is the problem getting the sub signal?
Evidently it’s not strong enough to trigger the sub to “wake up”. You can either have the sub on “auto” or on “Rem” setting. Rem is if you have a remote wire from your head unit. As far as I know, I don’t. So, it’s on auto. I have an LOC if needed, but the powered sub I purchased is set up to receive a high level input straight from the car’s speaker wires (aka - no RCA plugs). I’ve tried both methods and neither work.

To be clear, the amp is looking for two inputs (+ and - from left and right). I am only supplying one input, and it’s from the sub in the back. I tried tying together all the +’s as well as all the -‘s, but no luck. Therefore, I think I’m stuck tapping into the door speakers. I really didn’t want to go that route because I don’t want to tear up the interior of my car.
Scottlarson737 is online now  
post #33 of 41 (permalink) Old 07-01-2019, 05:35 PM
Senior Member
 
ALFAOFFROAD's Avatar
 
Join Date: Jul 2018
Posts: 1,110
Did you try running 2 lines parallel off of each + & - to go to the amp?

2018 Stelvio 2.0T AWD

Opinions on Automobiles
https://www.youtube.com/channel/UCPc...CMdK6vlFLuSWLQ
ALFAOFFROAD is online now  
post #34 of 41 (permalink) Old 07-01-2019, 07:04 PM
Member
 
Scottlarson737's Avatar
 
Join Date: May 2019
Posts: 62
Quote:
Originally Posted by ALFAOFFROAD View Post
Did you try running 2 lines parallel off of each + & - to go to the amp?
Nope. That is certainly something I could try. My only thought is that I don’t think by running in parallel the signal doubles in strength. I’m no electrician . . .
Scottlarson737 is online now  
post #35 of 41 (permalink) Old 07-02-2019, 06:25 PM
Senior Member
 
ALFAOFFROAD's Avatar
 
Join Date: Jul 2018
Posts: 1,110
Lowers resistance which raises current.


You may want to lower your gains...also might want to test the circuit for resistance and to be sure what is it, and that the amp can handle the lower OHM. Chances are you will be fine though, most amps are designed for something like that. You aren't talking about going from 4 ohm to 1, more like 4 to 2, or 8 to 4.


Running is series raises resistance and lowers current so kinda makes sense that wouldn't work.


Safest in a situation like this would be to check with an install shop, or maybe call the manufacturer of the amp and ask them....

2018 Stelvio 2.0T AWD

Opinions on Automobiles
https://www.youtube.com/channel/UCPc...CMdK6vlFLuSWLQ
ALFAOFFROAD is online now  
post #36 of 41 (permalink) Old 07-11-2019, 09:24 AM
Member
 
Scottlarson737's Avatar
 
Join Date: May 2019
Posts: 62
Well as it turns out, my sub was bad. Returned it and received a new one. Works awesome. I hooked up only my rear sub (I have the HK system) wires, ground, and power cable, and off she went! Listened to the Batman Returns soundtrack . . . totally awesome now! I can’t believe how this one change totally fills out the sound.
Scottlarson737 is online now  
post #37 of 41 (permalink) Old 07-11-2019, 06:57 PM
Senior Member
 
ALFAOFFROAD's Avatar
 
Join Date: Jul 2018
Posts: 1,110
Dang it.

You said Batman Returns...my brain jumps to the first Batman soundtrack...

Now I have to go listen to Batdance.

Thanks for that...

Glad your sub works though!!!

2018 Stelvio 2.0T AWD

Opinions on Automobiles
https://www.youtube.com/channel/UCPc...CMdK6vlFLuSWLQ
ALFAOFFROAD is online now  
post #38 of 41 (permalink) Old 08-15-2019, 04:05 PM
Junior Member
 
kennethTB's Avatar
 
Join Date: May 2019
Posts: 8
Well, when I needed good subwoofers for my car, I've simply took a pair of Rockville (like over here: https://carinmydna.com/best-15-inch-...fer-under-200/), and what I can say for sure - they cost their price, totally. With a good sound card it will give you awesome result, with a clear audio, no matter what you're gonna listen a pop music, rap or hard rock. I'm totally satisfied with that decision.

Last edited by kennethTB; 08-15-2019 at 04:09 PM.
kennethTB is offline  
post #39 of 41 (permalink) Old 08-15-2019, 04:06 PM
Junior Member
 
kennethTB's Avatar
 
Join Date: May 2019
Posts: 8
Quote:
Well as it turns out, my sub was bad. Returned it and received a new one. Works awesome. I hooked up only my rear sub (I have the HK system) wires, ground, and power cable, and off she went! Listened to the Batman Returns soundtrack . . . totally awesome now! I can’t believe how this one change totally fills out the sound.
Yeah, it always can be clear when you have a good comparison.
kennethTB is offline  
post #40 of 41 (permalink) Old 09-03-2019, 10:36 PM
Junior Member
 
Littlell's Avatar
 
Join Date: Jul 2019
Posts: 1
Now that you had it installed for a while have you had any issues with ventilation? I'm having mine installed this week but considering mounting it to the backseat because I've read these have issues without proper ventilation.
Littlell is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
HK Stereo System Quality? MartinC Alfa Romeo Stelvio General Discussion Forum 142 04-28-2019 10:07 AM
CarPlay vs Alfa Infotainment System skr9 Audio And Stereo 6 03-03-2019 03:22 AM
Adding Subwoofer - Non-HK System SEARCH Audio And Stereo 5 02-05-2019 11:21 AM
Collision warning system Pgiulekas Stelvio Complaints, Issues And Problems 23 10-23-2018 02:35 PM
Alfa Romeo Stelvio Performance Overview Stelvio_Admin 2017+ Alfa Romeo Stelvio News 4 07-13-2017 11:40 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome