Iphone cannot load favorites or contacts - Alfa Romeo Stelvio Forum
 2Likes
Reply
 
LinkBack Thread Tools
post #1 of 18 (permalink) Old 09-22-2019, 04:32 PM Thread Starter
Member
 
Lawyerboy's Avatar
 
Join Date: Apr 2019
Location: Central Florida, Orlando Area
Posts: 43
Iphone cannot load favorites or contacts

So I jinxed myself. I had been blessed with no major issues on my 18 TI Sport. Until now, it seems. IOS 13, and the iPhone XR. Now the infotainment did not recognize the favorites. Then the tried and true unpair and pair, only with favorites and not all contacts, does not work. Used to be that you paired only favorites, and they appeared as contacts. Then you go to favorites tab, and add to favorites from the favorites that were the only ones loading into contacts. After you load the favorites from contacts as actual favorites, you then click on adding all contacts, and your original favorites remain, and contacts populate. Seems a cumbersome process but this is how Alfa does things, and I have an 88 Spider Quad, so I know first-hand nothing is usually easy with Alfa. BUT, for me, no longer am I an Eh, its an Alfa, kind of person. I want this basic thing to work. I don't have Carplay, when I was told it was on 18s, and now you tell me that my phone can't load favorites into it for me to make hands free calls? Says searching, but won't even give me the menu to add a favorite when the actual phone favorites are right there, in the contact list. I will take it in, and since not my daily driver, they can keep it as long as necessary. It's under warranty, and I would like it to work. So I join the club of those with issues. Hopefully this is a minor issue of an update. Mark
Lawyerboy is online now  
post #2 of 18 (permalink) Old 09-24-2019, 03:07 PM
Junior Member
 
Meggorock's Avatar
 
Join Date: Jul 2019
Location: Dallas, Texas
Posts: 25
So, no CarPlay, but the new iOS isn't connecting to your stereo? Uh oh that's annoying. Keep us posted on any progress.

2018 Stelvio Sport Q4; Volcano black yellow calipers & 5-hole wheels; sunroof; 8.8" Bluetooth 3D Nav/Sirius; 9/17 build
Meggorock is offline  
post #3 of 18 (permalink) Old 09-24-2019, 03:07 PM
Member
 
OhioF1's Avatar
 
Join Date: Mar 2019
Location: Cleveland, Ohio
Posts: 95
Thank you for posting this. I have the iphone XR but still on IOS 12.4.1. (Stelvio is also a 2018) Let us know what you find out. I won't update if this is going to be an issue.
Meggorock likes this.

2018 Base Stelvio - Vulcano Black / Chocolate Interior.
OhioF1 is offline  
post #4 of 18 (permalink) Old 09-24-2019, 06:03 PM Thread Starter
Member
 
Lawyerboy's Avatar
 
Join Date: Apr 2019
Location: Central Florida, Orlando Area
Posts: 43
Appointment with dealer on the 5th and they said my pre car play system is current on firmware but will try to re-flash. Basically, I can see my phone favorites in the contacts of the car but I did not sync all contacts yet. Now, I would expect in the favorites section of the car an option to add to favorites but no such menu. Only spooling saying searching for contacts. This is iOS 13 and xr. Will keep you posted. Mark
Lawyerboy is online now  
post #5 of 18 (permalink) Old 09-24-2019, 06:56 PM Thread Starter
Member
 
Lawyerboy's Avatar
 
Join Date: Apr 2019
Location: Central Florida, Orlando Area
Posts: 43
Beware folks of possible issues with iOS 13. So now all contacts synced but not those in phone favorites. In favorite section on car it’s spools saying search in progress. No ability to make a contact a favorite. No longer access to text messages either. I am going to contact Alfa cards folks. This is a real issue folks. You buy a car with expectations basic functions in the system will work. iPhone is a major phone out there and I hope flashing is a save here. Clearly if a contact is in the car system the car system should be able to have its internal menu offerings.
Lawyerboy is online now  
post #6 of 18 (permalink) Old 09-25-2019, 01:15 PM
Sox
Junior Member
 
Join Date: May 2019
Posts: 3
I have same problem
Will watch the thread for news.
Thanks for posting
claffeeba likes this.
Sox is offline  
post #7 of 18 (permalink) Old 09-25-2019, 03:22 PM
Junior Member
 
Join Date: May 2019
Location: Milford, Connecticut
Posts: 4
Garage
I also had/ have the same problem with my Note 8 and now my Note 10+. It loads all the contacts but when you try to add favorites all i get is "No Item to Select". Worked with AlfaCare they were able to load an older android phone. They told me to bring it to a Dealer to see if they could load it, that was back in May. Will be going soon to do current fuel gauge recall will see if there is a current fix for that and Wide Screen Andriod Auto............ 2018 Stelivo Quad
zacman1955 is online now  
post #8 of 18 (permalink) Old 09-25-2019, 04:44 PM Thread Starter
Member
 
Lawyerboy's Avatar
 
Join Date: Apr 2019
Location: Central Florida, Orlando Area
Posts: 43
Exactly. So the way I could get phone favorites in the car is only syncing favorites. They show up as contacts. Then I used to be able to add them to favorites and once in favorites folder of car, then load balance of all contacts. Now, like you said no item to select but contacts do show the phone favorites. There should be something to select. Now also the sms messaging no longer available and yes, enabled on phone and car. Alfa Carr’s reaches out and I provided my information and no follow up yet. When a vehicle like this cannot work with the most common of phones, that is not a good thing. I will await assistance and re flash to see if that helps.
Lawyerboy is online now  
post #9 of 18 (permalink) Old 09-27-2019, 05:06 PM Thread Starter
Member
 
Lawyerboy's Avatar
 
Join Date: Apr 2019
Location: Central Florida, Orlando Area
Posts: 43
Update. So today text messages came alive again in system. Phone favorites are in the system but cannot be added as favorites in the system. No menu option to select a contact to add as a favorite. Either spooling saying searching or it says no item to select, which does not make sense because there are contacts to select from. Alfa care had a u connect person call me today. He listened and I did tell him the crazy way just to get favorites from phone into system. I told him comments above from others and a friend with a 17 Guilia support this is an older problem than simply an iOS 13 issue, for example, he said Apple releases new operating systems very often and their engineers can’t keep up, and Apple doesn’t share before the iOS releases so it’s a game of catch up. My fear is Alfa engineers care more about newer model years than my old 18 stelvio system and I can’t see firmware to ever fix. He promised to email me his contact info but haven’t seen it yet. Keep you posted but if you have issues assigning favorites in your vehicles, chime in pls.
Lawyerboy is online now  
post #10 of 18 (permalink) Old 10-01-2019, 01:37 PM
Junior Member
 
Join Date: Oct 2019
Location: Copenhagen, Denmark
Posts: 1
I have the same issue in my 2017 Alfa with the DAB radio without sat nav or Apple Carplay. I have an iOS13.1 iPhone and it only shows the phone numbers, but not the names in recent calls. In contacts it is empty, but shows the ‘spooling wheel” as if it is trying to load the contacts, but nothing ever happens. This have been an issue since i got the new phone on 20 September and the problem is the same with my old iPhone (also with iOS13.0).

If i connect my girlfriends iPhone with iOs 12.x it connects flawlessly and shows names of the contacts in recent calls and in contacts.

If i connect my new iPhone 11 with iOS 13.1 to her car - a Fiat 500x - it shows names in both recent calls and in contacts.

It is hence for sure a problem with the infotainment system in the Alfa. I have asked on a Alfa Forum in Denmark (Danish Alfa Owners Club) and one other had the issue, but it was solved with a re-pairing with the car, he also have iOS13.

I have hence asked what software version he has in his Alfa’s infotainment system, as i had mine updated on 11 th July 2019. If he has the same software I am really confused.... I will update this thread, when he replies on the danish forum.

I hope that I am just missing the latest infotainment update as the car is going in for the 2nd year service here in October. (fingers crossed).

The car itself has worked problem free - other than this issue- since i got it brand new , and spec’ ed as i wanted it. Only normal service a year ago. This is my fourth Alfa, and i have also had a Lancia and a few Fiats (as car no. 2) the past 20 years.
svastrup is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome