New Owner - Alfa Romeo Stelvio Forum
 4Likes
  • 2 Post By asapjun
  • 1 Post By asapjun
  • 1 Post By Banffstelvio
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-14-2019, 09:29 PM Thread Starter
Junior Member
 
asapjun's Avatar
 
Join Date: Apr 2019
Posts: 16
New Owner

Well we are new owners of a brand new 2018 Stelvio TI Sport … we are 600 KM away from the nearest Alfa dealer .. so we have never seen one or driven one.(commercials and you tube only) .. to make a long story short we hopped in a plane .. uber to dealership and after one walk around and a 15 minute test drive we drove it home… and the more we drive it the more we like it!!! But not having local service other than Fiat/Chrysler dealership for the oil service but not warranty could be risky but worth it .. because we love the thing. A couple bugs to work out but this is why I joined the forum.
lost1750GTV and Banffstelvio like this.
asapjun is offline  
post #2 of 5 (permalink) Old 04-14-2019, 09:54 PM
Senior Member
 
Banffstelvio's Avatar
 
Join Date: Apr 2018
Location: Banff, Alberta Canada
Posts: 262
I am almost at a full year of owning mine. Dealership is about 175KM away.

So far only one "check engine" light that needed to go there and took 20 min to do a software update.

I think I have had 3 recall items and just got the latest for the adaptive cruise control.

Oil change due in a couple weeks

So far way less issues than my last one that was a GMC Yukon. That was a many many trip and stays at the dealership for problems
Banffstelvio is offline  
post #3 of 5 (permalink) Old 04-14-2019, 11:12 PM Thread Starter
Junior Member
 
asapjun's Avatar
 
Join Date: Apr 2019
Posts: 16
I see you are in Banff I am in Vernon .. flew to Calgary to get ours...in a couple weeks we go to Vancouver ..and have already set up a sch appointment at an Alfa dealership to deal with outstanding recalls .. which require a few software re-sets… but today backing down and out of drive way .. I got a engine warning –[email protected] unavailable and engine service required … same thing happened to my son in his new dodge half ton about a year ago… exact same thing and exact same place.. fluke or ?? backing out of driveway … ??? He required a reset at the dealership… his turbo went into limp mode… mine in the stelvio seems to still be ok … but it will not allow me to change driver modes…. Wondering if this for sure requires a dealership re-set …..or… there is a work around ?
Banffstelvio likes this.
asapjun is offline  
post #4 of 5 (permalink) Old 04-14-2019, 11:17 PM
Senior Member
 
Banffstelvio's Avatar
 
Join Date: Apr 2018
Location: Banff, Alberta Canada
Posts: 262
Quote:
Originally Posted by asapjun View Post
I see you are in Banff I am in Vernon .. flew to Calgary to get ours...in a couple weeks we go to Vancouver ..and have already set up a sch appointment at an Alfa dealership to deal with outstanding recalls .. which require a few software re-sets… but today backing down and out of drive way .. I got a engine warning –[email protected] unavailable and engine service required … same thing happened to my son in his new dodge half ton about a year ago… exact same thing and exact same place.. fluke or ?? backing out of driveway … ??? He required a reset at the dealership… his turbo went into limp mode… mine in the stelvio seems to still be ok … but it will not allow me to change driver modes…. Wondering if this for sure requires a dealership re-set …..or… there is a work around ?

That was exactly what happened to mine. Software update and it took 20 minutes.
asapjun likes this.
Banffstelvio is offline  
post #5 of 5 (permalink) Old 04-18-2019, 01:10 AM Thread Starter
Junior Member
 
asapjun's Avatar
 
Join Date: Apr 2019
Posts: 16
Power on and off then on while depressing the [email protected] button fixed the service engine code error..
asapjun is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Owner of Used Stelvio List of "Problems" patrickmyerspt Stelvio Complaints, Issues And Problems 18 02-01-2019 07:03 PM
New Owner 19' Stelvio Ti Chip Connell New Member Introductions 10 01-15-2019 05:20 PM
New owner, London, UK deanwillars Alfa Romeo Stelvio Owners Registry And Check In Area 4 11-16-2018 05:37 AM
New Owner Vulcan Black Quad ripuanewass Stelvio Quadrifoglio Discussion 14 09-03-2018 09:07 PM
Prospective new owner bustahinds Alfa Romeo Stelvio Owners Registry And Check In Area 5 07-01-2018 03:40 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome