Just purchased new 2019 stelvio q4 but.... - Alfa Romeo Stelvio Forum
 1Likes
Reply
LinkBack Thread Tools
post #1 of 13 (permalink) Unread 05-07-2019, 09:23 PM Thread Starter
Junior Member
 
Ddominator1's Avatar
 
Join Date: May 2019
Posts: 5
Just purchased new 2019 stelvio q4 but....

Hey guys just got my new Tri coat trofeo stelvio ! Had to sooth my soul after Selling my 17 dodge viper acr( Barrett Jackson) bit of a change for me but absolutelyLove this car but... at 200 miles thew a TAC code ..(in sport mode .. paddle shifting in 3rd gear 5000rpm.. then poof... drivable but lost all Modes.. please tell me this Isn’t a chronic reliability problem with this gorgeous vehicle. Gonna dealer it in am. Had this one delivered from dealership new in Illinois but luckily have one local. Gotta love electronics ... help anyone ?
Ddominator1 is online now  
post #2 of 13 (permalink) Unread 05-07-2019, 09:31 PM
Senior Member
 
NYCSTELVIO's Avatar
 
Join Date: Jun 2018
Location: Upper East Side, NYC
Posts: 151
Quote:
Originally Posted by Ddominator1 View Post
Hey guys just got my new Tri coat trofeo stelvio ! Had to sooth my soul after Selling my 17 dodge viper acr( Barrett Jackson) bit of a change for me but absolutelyLove this car but... at 200 miles thew a TAC code ..(in sport mode .. paddle shifting in 3rd gear 5000rpm.. then poof... drivable but lost all Modes.. please tell me this Isn’t a chronic reliability problem with this gorgeous vehicle. Gonna dealer it in am. Had this one delivered from dealership new in Illinois but luckily have one local. Gotta love electronics ... help anyone ?
Sorry to hear that..Only one way to tell is to scan the OBD system to see what codes come up.

2018 Stelvio Sport AWD
Vesuvio/Red
EuroCompulsion V2 Intake,Red Start/Stop Button, Gunmetal Powedercoated Wheels, 20% tints all around, Debadged, Carbon Interior Bits, Stelvio Quadrofoglio Fender Flares, Farad Slim Door visors, Carbon front V grill, Center Muffler Resonator delete, EMC Pro Piggyback
NYCSTELVIO is online now  
post #3 of 13 (permalink) Unread 05-07-2019, 09:41 PM
Senior Member
 
Join Date: Aug 2017
Location: MAgical
Posts: 1,703
it isn't a chronic reliability problem - but some new vehicles sometimes have a pita thing appear.

"Gotta love electronics'- yup
lost1750GTV is online now  
post #4 of 13 (permalink) Unread 05-07-2019, 10:41 PM Thread Starter
Junior Member
 
Ddominator1's Avatar
 
Join Date: May 2019
Posts: 5
Sorry. .. meant ETC. electronic throttle control guys.
Ddominator1 is online now  
post #5 of 13 (permalink) Unread 05-07-2019, 10:57 PM
Member
 
Kctime's Avatar
 
Join Date: Mar 2019
Posts: 41
Same thing happened to me five hours after delivery, then two weeks later. First suspected to be bad battery, second faulty wastegate actuator. I’m having hope that it’s just gremlins that have to be discovered. If it didn’t drive so doggone good I’d lose patience.

18 AR Stelvio Quad, Vesuvio Grey
19 BMW X5
16 BMW M2

Last edited by Kctime; 05-07-2019 at 11:01 PM.
Kctime is online now  
post #6 of 13 (permalink) Unread 05-08-2019, 09:21 AM
Senior Member
 
Join Date: Sep 2018
Location: Chicago, IL
Posts: 157
I had something similar when I was, ah, testing the handling in the snow, for science. Limped home, shut it down for an hour and on "reboot" all was normal. Hasn't happened since and I may have done some additional handling science since with no issues.
lost1750GTV likes this.
Jay-Ten is online now  
post #7 of 13 (permalink) Unread 05-08-2019, 10:50 AM
Member
 
Join Date: Aug 2018
Location: Northern Virginia USA
Posts: 40
I had that happen a couple weeks ago. The dealer said the controller was faulty and replaced it. It was about a 2 day turn around and so far I haven't had any issues, but others have had their error traced down to a bad battery.

If you search the forum you'll see a couple other threads about it.

Welcome and congrads on the purchase!
LeoManiaX is online now  
post #8 of 13 (permalink) Unread 05-08-2019, 01:13 PM Thread Starter
Junior Member
 
Ddominator1's Avatar
 
Join Date: May 2019
Posts: 5
Quote:
Originally Posted by LeoManiaX View Post
I had that happen a couple weeks ago. The dealer said the controller was faulty and replaced it. It was about a 2 day turn around and so far I haven't had any issues, but others have had their error traced down to a bad battery.

If you search the forum you'll see a couple other threads about it.

Welcome and congrads on the purchase!
Thanks man... love the car. 1st alpha ever. Bummed about this Throttle thing tho. Still doing upon restarting this am. Getting into dealer this Friday. Still can drive as light is solid , not flashing but all modes are disabled so o guess I’m driving in some sort told hibernation mode lol. Maybe same issue ?? I wonder if this is a recall in the future as seen a few w similar probs.
Ddominator1 is online now  
post #9 of 13 (permalink) Unread 05-08-2019, 01:16 PM Thread Starter
Junior Member
 
Ddominator1's Avatar
 
Join Date: May 2019
Posts: 5
Quote:
Originally Posted by Kctime View Post
Same thing happened to me five hours after delivery, then two weeks later. First suspected to be bad battery, second faulty wastegate actuator. I’m having hope that it’s just gremlins that have to be discovered. If it didn’t drive so doggone good I’d lose patience.
Are you still having probs with it. Restarted this am. And Warning still solid .. at least not flashing. Car is drivable but in back up mode. Dealer scheduled this Friday. Ughhh
Ddominator1 is online now  
post #10 of 13 (permalink) Unread 05-08-2019, 09:40 PM
Senior Member
 
ttaidapos's Avatar
 
Join Date: Jun 2018
Posts: 226
Remove terminal from battery for 15-20min and then reconnect. That will get you a nice hard reboot before dealing with the dealer. Depending on how long your car was sitting, it may need a battery replacement. There was an issue with the original batteries and different ones are being installed now to remediate the issue. Some people never had the issue with the originals.
ttaidapos is offline  
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
stelvio 2019 - lights vanikpavol New Member Introductions 8 03-29-2019 08:41 PM
Stelvio Quadrifoglio Exterior Diagrams and part numbers Flunx Alfa Romeo Stelvio DIY And How To 12 08-28-2018 06:21 AM
What To Like About The Stelvio Stelvio_Admin 2017+ Alfa Romeo Stelvio News 0 01-09-2018 11:44 AM
Overview of the All-New Stelvio Stelvio_Admin 2017+ Alfa Romeo Stelvio News 1 11-14-2017 02:30 PM
Alfa Romeo Stelvio Performance Overview Stelvio_Admin 2017+ Alfa Romeo Stelvio News 4 07-13-2017 11:40 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome