2 issues - Alfa Romeo Stelvio Forum
 3Likes
Reply
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old Yesterday, 06:53 PM Thread Starter
Junior Member
 
Scottlarson737's Avatar
 
Join Date: May 2019
Posts: 9
2 issues

#1: how do my rear passenger get air? The air vents don’t seem to blow any air and I can’t see where I can adjust it.
#2: I was driving and all of a sudden my infotainment center went black. It quickly restored itself (showed the Alfa Shield, etc). Anybody else experience this?

Another minor issue: rear hatch button in the rear gate sticks. Hasn’t caused any random openings . . . Yet.
Scottlarson737 is online now  
post #2 of 12 (permalink) Old Yesterday, 07:18 PM
Junior Member
 
Jpizzo's Avatar
 
Join Date: Mar 2019
Posts: 17
I can only comment on Issue 2. My infotainment system reboots about once a month. It mostly happens when my phone is physically connected to via the USB and using Apple CarPlay and using the Waze application. Therefore, it’s hard to say the problem is with the infotainment system or CarPlay causing the problem.
Jpizzo is online now  
post #3 of 12 (permalink) Old Yesterday, 07:19 PM
Junior Member
 
Join Date: Dec 2018
Posts: 27
Quote:
Originally Posted by Scottlarson737 View Post
#1: how do my rear passenger get air? The air vents donít seem to blow any air and I canít see where I can adjust it.
#2: I was driving and all of a sudden my infotainment center went black. It quickly restored itself (showed the Alfa Shield, etc). Anybody else experience this?

Another minor issue: rear hatch button in the rear gate sticks. Hasnít caused any random openings . . . Yet.
Not sure about your first 2 issues. sticky rear hatch button is more prone to not closing vs opening on its own. it all has to do with the weather. i choose to just use the lock and close button when its colder outside
JFerraro819 is online now  
post #4 of 12 (permalink) Old Yesterday, 08:15 PM
Member
 
Join Date: Apr 2019
Posts: 35
Quote:
Originally Posted by Scottlarson737 View Post
#1: how do my rear passenger get air? The air vents donít seem to blow any air and I canít see where I can adjust it.
#2: I was driving and all of a sudden my infotainment center went black. It quickly restored itself (showed the Alfa Shield, etc). Anybody else experience this?

Another minor issue: rear hatch button in the rear gate sticks. Hasnít caused any random openings . . . Yet.
Make sure infotainment software is up to rev .059 and that should help.

I have the same issue with the sticky button and my dealer has a new button on order.

And have you turned the rear vents to let air flow through? If you have, then play with the directional button on the climate controls until it's directed to the floor.

2018 Alfa Romeo Stelvio Ti Sport, Trofeo White with Red interior, all tech options
WoodstockDude is online now  
post #5 of 12 (permalink) Old Yesterday, 10:23 PM
Senior Member
 
Join Date: Apr 2018
Location: Las Vegas
Posts: 176
#1 Open the air vents by turning them counter clockwise. Close them by turning them clockwise. #2 Two weeks ago I upgraded my infotainment software from 002.009.043 to 002.009.059 since the upgrade was supposed to eliminate spontaneous rebooting and the popping sound from the speakers. I had this issue start at the 13th month of ownership, which I though was odd given there had been no issues up to that point. The upgraded software has been a little improvement with less popping but today when I started the Stelvio, after going to lunch for an hour, the radio came on but the video display was blank. I drove back to work 5 minutes away and turned the vehicle off when I parked and the video display came back on, so I think the 002.009.059 upgrade is not glitch free. Supposedly there will be another upgrade end of this year.
JimW is offline  
post #6 of 12 (permalink) Old Today, 08:23 AM
Super Moderator
 
Scalewoodman's Avatar
 
Join Date: Nov 2017
Location: Lancaster, Pennsylvania USA
Posts: 1,460
I have observed the blanking phenomenon only when Sirius XM is updating channels; appears to be a restart. Possibly the issue. Rear vents work well- if opened. Good luck + hope all is well!

2018 Stelvio - Vulcano, Chocolate interior - 20" wheels + Yellow calipers / safety pkgs - Build: July 2017 - Godetevi la corsa!
Scalewoodman is online now  
post #7 of 12 (permalink) Old Today, 09:31 AM Thread Starter
Junior Member
 
Scottlarson737's Avatar
 
Join Date: May 2019
Posts: 9
Thanks so much for the replies! Ok, on the software update: how do I do this? I looked at doing this about a week ago and came to a dead end (evidently you can’t manually do this anymore?). Do I have to take the car in to a dealership to update the software?

Sticky button: yeah, I’ve been using the key fob. Not a biggie, just an annoyance.

Rear air control: AH! TURN THEM! Haha, oops. Thanks for the education!
Scottlarson737 is online now  
post #8 of 12 (permalink) Old Today, 10:59 AM
Senior Member
 
ViscontiVerde 164L*'s Avatar
 
Join Date: Apr 2018
Posts: 1,070
Garage
A grain of something gets between the two buttons. Someone solved problem by passing something real thin like a plastic card between the switches to get the construction out of the way.....worked for me.


I have not rebooted since the updates were done but it used to happen monthly


Since the updates and replacement of outdoor temp sensor, it has been pretty darn accurate.


Only real issue is grossly inadequate RAM in the system to allow Ipod s to fully integrate..should be an easy fix but they don't seem to want to touch this one.

2018 Alfa Romeo Stelvio TiSport EC Phase 2 w/V2 intake, Remus Catback ~390HP / 442ft-lb Tq Visconti Verde, Chocolate Interior, Quadrofoglio wheels w/PZ4's
2016 Maserati GranTurismo Sport Custom blue tone, Grigio chrono leather w/full interior MC Carbon Fiber trim, NA 4.7L Ferrari V8
2016 Range Rover Sport HSE 3.0SC tuned by ETG 456HP/414Tq, Montalcino Red, Ivory
2012 Maxda MX5 Miata GTPRHT True Red, Black
2011 Lotus Evora S Persian Blue,Black Suedetex (Track specialist)
ViscontiVerde 164L* is online now  
post #9 of 12 (permalink) Old Today, 11:06 AM
Member
 
Join Date: Apr 2019
Posts: 35
Yes, you have to go to the dealer for the software upgrade.
ifly4fun likes this.

2018 Alfa Romeo Stelvio Ti Sport, Trofeo White with Red interior, all tech options
WoodstockDude is online now  
post #10 of 12 (permalink) Old Today, 01:13 PM
Senior Member
 
ifly4fun's Avatar
 
Join Date: Oct 2018
Location: Virginia
Posts: 163
Quote:
Originally Posted by WoodstockDude View Post
Yes, you have to go to the dealer for the software upgrade.
Make 'em replace the button while you're in there. It seems to be a common issue.
ifly4fun is online now  
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
Power window issues and a couple other things sweetness34 Stelvio Complaints, Issues And Problems 24 05-12-2019 02:10 PM
Multiple Issues - Dropping off for service tomorrow (4th time) sweetness34 Stelvio Complaints, Issues And Problems 17 05-11-2019 06:44 AM
Issues with Stelvio 2018 ARStelvio Alfa Romeo Stelvio General Discussion Forum 69 03-03-2019 08:29 AM
Major Electrical Issues Moholland Stelvio Complaints, Issues And Problems 57 02-14-2019 07:48 AM
Two big issues ChiStelvio786 Alfa Romeo Stelvio General Discussion Forum 8 07-27-2018 02:45 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome