Alfa Romeo Stelvio Forum banner
21 - 29 of 29 Posts

·
Registered
Joined
·
109 Posts
Got the Uconnect service error msg again yesterday. I've never seen a msg asking about an update. Is there any way I can check to see if I've gotten the update or check the firmware version?

If I haven't gotten it over the air I guess my only option is to go to the dealer and have them apply it?
 

·
Registered
2020 Stelvio Base RWD
Joined
·
634 Posts
I have got the second message, and I think that I screwed it up. After I have clicked on the update button, I waited a while, but screen wasn't showing anything, I was late from work, and I have just turned the car off. After turning it on, there was a message that Assist call is not available, and I have to see the dealer about that. Most likely it needs reflashing by the dealer.
I don't understand, why they did not include something, that shows the progress of the update?
 

·
Registered
Joined
·
500 Posts
I have got the second message, and I think that I screwed it up. After I have clicked on the update button, I waited a while, but screen wasn't showing anything, I was late from work, and I have just turned the car off. After turning it on, there was a message that Assist call is not available, and I have to see the dealer about that. Most likely it needs reflashing by the dealer.
I don't understand, why they did not include something, that shows the progress of the update?
I've seen that message occasionally, but it goes away on next start, I would not worry unless it keeps popping up.
As far as progress bar and shutting the car off, it seems to continue to update after you turn the car off, so I suspect the view they lack of progress bar as not a needed item.
 

·
Registered
Joined
·
500 Posts
What that Assist call even do?
You are saying, that it may be OK as it is?
Assist Call, Roadside assistance, etc, are the SOS phone call process via the telematics box to make an emergency call from the car itself, it also has a cellular modem that can transmit signals for the remote access features.

Occasionally I will start the car and get that warning saying it needs to go to a dealer, but then it will workfine and does not give the notice again, so clearly the box resets itself at some point and decides the error is not longer active.
If you get the alert every time you start the car, yes I would take it to the dealer, if you get the alert every few months, things are probably fine and I'd mention it on the next dealer visit if you are so inclined.
 

·
Registered
Joined
·
604 Posts
Discussion Starter · #27 ·
Got the Uconnect service error msg again yesterday. I've never seen a msg asking about an update. Is there any way I can check to see if I've gotten the update or check the firmware version?

If I haven't gotten it over the air I guess my only option is to go to the dealer and have them apply it?
DavidM17,

If you would like to discuss this further with us, please send us a PM with your VIN, we'd be happy to look into this issue further for you.

William
Alfa Romeo Cares
 

·
Registered
Joined
·
604 Posts
Discussion Starter · #28 ·
I have got the second message, and I think that I screwed it up. After I have clicked on the update button, I waited a while, but screen wasn't showing anything, I was late from work, and I have just turned the car off. After turning it on, there was a message that Assist call is not available, and I have to see the dealer about that. Most likely it needs reflashing by the dealer.
I don't understand, why they did not include something, that shows the progress of the update?
Hello tibimakai,

Thank you for grabbing our attention. If you wish to discuss this further with us, please send us a PM with your VIN, we'd be happy to look into this further for you.

William
Alfa Romeo Cares
 
21 - 29 of 29 Posts
Top