Alfa Romeo Stelvio Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter · #1 ·
Hi All,

Has anyone seen an issue with Blind Spot warning coming up periodically with a message stating that Blind Spot System not available, service required along with a blinking odometer? Last time this happened the issue was ongoing for a week or so until I washed my Stelvio and then promptly went away.

thanks in advance
Alex..
 

·
Registered
2018 Stelvio Q4 Sport, MonteCarlo Blue
Joined
·
77 Posts
It happened a lot in my Ford Fusion. Some of the sensors are mounted behind body panels/bumpers, which already diminishes their ability. When the body is dirty it can scatter the microwaves too much. When the receiver is seeing a lot of scatter (due to dirt, snow, rain, etc) then the system disables because the range is greatly reduced. Dusting/Cleaning the areas the sensors are looking thru should bring it back online, as you found.
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #3 ·
It happened a lot in my Ford Fusion. Some of the sensors are mounted behind body panels/bumpers, which already diminishes their ability. When the body is dirty it can scatter the microwaves too much. When the receiver is seeing a lot of scatter (due to dirt, snow, rain, etc) then the system disables because the range is greatly reduced. Dusting/Cleaning the areas the sensors are looking thru should bring it back online, as you found.
Makes sense. I did have a dealer appt to have them look at the issue. They did note the stored error which came back after they cleared it. Not sure what the error was as that wasn’t documented and when I was leaving blind spot was still functioning. Unfortunately I couldn’t leave the car with them to finish troubleshooting, but I have another appt this coming Friday to hopefully get this resolved as the issue did come back the day after the dealer visit.
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #4 ·
At this point my car has been camping out at the dealer for a full week with them trying to troubleshoot the issue. According to the last update from them a few days ago (getting updates from this particular dealer is like pulling teeth) they did a software update (possibly BCM, the service writer wasn't sure) and the errors are still coming up. They are trying to figure out next steps and possibly ordering parts.
 

·
Registered
'18 Stelvio
Joined
·
1 Posts
I have a 2018 stelvio as well and have been to the dealership twice, they have had my car for approx. 8 business days total and it will be going back again. I drive over an hour each way to my closest dealer. I was dismayed upon picking up my vehicle after the first service where they replaced my radiator in addition to diagnosing multiple concerns, only to find the charge air cooling expansion tank pressure cap removed and sitting behind the tank, I noticed some damage on my rear bumper that I hadn't seen before also, that would later be repaired under warranty as clear peel. The moment I hop in the car and start it up I am greeted by the blindspot monitoring temporarily unavailable message that I've come to know so well. The second time around they dropped off a loaner at my work and drove my car back to the dealer. They repainted rear bumper and programmed instrument cluster plus both blindspot modules. I drove it home and the next morning the message reappeared at first startup. The TSB they referenced was 08-062-19, and in summary on my RO it is explained as "update all pcms in line with lbss,rbss,bcm,ipc,and ext"
I have no idea why they didnt program the other modules listed in the tsb. I still need to read the actual full tsb when I am at work tomorrow and determine what ext stands for. I did use my verus scan tool quickly tonight to check the last flash odo. reading on bcm and it was infact not current. it was done at 39073mi, currently at 47509mi. I have vastly more total faults in modules now after they reprogrammed these things than the 2 total faults I had before they ever touched my car, both of those two faults were for the blindspot system. I reached out to alfa customer support today with an email after discussing things with the service advisor and manager at this dealership. But above all, driving a 500X as a loaner is like throwing salt in a wound LOL
 
1 - 6 of 6 Posts
Top