Alfa Romeo Stelvio Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 2018 Stelvio’s center display went dark suddenly while I was trying to turn on high beam setting. I has been blinking since then. Is there a fix I can perform myself? Can someone help please?
 

·
Registered
Joined
·
672 Posts
My 2018 Stelvio’s center display went dark suddenly while I was trying to turn on high beam setting. I has been blinking since then. Is there a fix I can perform myself? Can someone help please?
Is it the center display, or just the odometer ?

regardless, you could try a basic reset: disconnect negative connection on battery for approx 15 minutes (it has a quick release, see your manual), then reconnect. You will probably get a lot of error lights. Reset with car horizontal, ignition on, turn steeringwheel end-to-end, then center.
This should reset all warning lights, any possibly remaining will reset after 4 or 5 starts.
 

·
Registered
2018 Stelvio/Black/Ti Sport
Joined
·
364 Posts
Is it the center display, or just the odometer ?

regardless, you could try a basic reset: disconnect negative connection on battery for approx 15 minutes (it has a quick release, see your manual), then reconnect. You will probably get a lot of error lights. Reset with car horizontal, ignition on, turn steeringwheel end-to-end, then center.
This should reset all warning lights, any possibly remaining will reset after 4 or 5 starts.
The member that just replied knew exactly what was wrong with symptoms I described about my Stelvio, and is likely right about what you should do if it doesn't "fix itself" in one or two starts.
 
1 - 4 of 4 Posts
Top