Alfa Romeo Stelvio Forum banner

1 - 20 of 56 Posts

·
Premium Member
2018 Stelvio Base 20" yellow calipers
Joined
·
1,504 Posts
Discussion Starter · #1 ·
37K all is well except I have lost the center display cluster between tachometer and speedometer. It pulses occasionally in the dark. There was no incident or unusual cause. I want to believe software but anyone else have this issue?
 

·
Premium Member
2018 Stelvio Base 20" yellow calipers
Joined
·
1,504 Posts
Discussion Starter · #3 ·
And just like that... Back to normal. Go figure. Will inquire at my 40K service in a couple of weeks. Back to our normally scheduled program...
 

·
Registered
Joined
·
57 Posts
Was fiddling with buttons I don't normally press whilst waiting to pick the Mrs up... found the dash light brightness toggle switch, since trying out the different brightness settings my display sometimes changes brightness.. suspect a loose connection in that switch.. might be worth rolling the switch a few times to see if it's working ok?
 

·
Registered
Joined
·
8 Posts
My center cluster started to go dark yesterday. It was intermittent. Regular service this week so hoping that they can correct this issue. Car has been perfect otherwise with 13,000 miles.
 

·
Registered
Joined
·
523 Posts
My center cluster started to go dark yesterday. It was intermittent. Regular service this week so hoping that they can correct this issue. Car has been perfect otherwise with 13,000 miles.
Hello CorgiE63,
We are certainly sorry to hear about your recent concern. Pleas keep us updated on your dealer findings. If any additional assistance is needed throughout this process, please do not hesitate reaching out to us.
Laura
AlfaRomeoCares
 

·
Registered
Joined
·
43 Posts
Italian car ? ;)
ha ha, that's probably it. mine still hasn't reset, maybe tomorrow morning. I seem to feel the car acts up whenever it rains, and it's been raining here all day. I also get the "sound system is unavailable" warning whenever it rains, but that doesn't seem to affect anything b/c I don't notice any problem other than the warning itself.
 

·
Registered
Joined
·
8 Posts
Hello CorgiE63,
We are certainly sorry to hear about your recent concern. Pleas keep us updated on your dealer findings. If any additional assistance is needed throughout this process, please do not hesitate reaching out to us.
Laura
AlfaRomeoCares
Thank you Laura. Car is going into the dealer this morning.
 

·
Registered
Joined
·
1 Posts
Guys, CorgiE63, how the story with a center display has finally finished? I'm having the same issue starting yesterday. Model year 2018, as yours. Is it necessary visiting dealer? KR, Tomasz
 

·
Registered
Joined
·
1,884 Posts
I see residual issues from the rear hatch water ingress back in the day.
 

·
Registered
Joined
·
2 Posts
Me too! 2018 car, Centre instrument panel not working . I used it in the rain this morning and on return journey it had gone dark!
I can’t see a fuse to pull, and dealer is 40 miles away! Anyone managed to get this resolved?
 

·
Registered
Joined
·
114 Posts
If your instrument panel is black, technicians are instructed to disconnect the battery and wait three minutes before reconnecting it. Then, they do this up to three times. If it is still black after the third time, the IPC gets replaced entirely. If it comes back to life, it gets reflashed.

Please see attached -- known issue across Giulia and Stelvio, super common.
 

Attachments

·
Registered
Joined
·
523 Posts
Me too! 2018 car, Centre instrument panel not working . I used it in the rain this morning and on return journey it had gone dark!
I can’t see a fuse to pull, and dealer is 40 miles away! Anyone managed to get this resolved?
Hello Jase111,
Would you mind following up with us via private message? I would be happy to learn more about your current concerns to determine how to best assist at this point. Hope to hear from you soon.
Laura
AlfaRomeoCares
 

·
Registered
Joined
·
2 Posts
Brilliant, Followed Bossanovas post, re battery disconnection. After disconnecting 3 times panel has come back to life.
Hopefully I can hold out until the next service before visiting the garage.?
Thanks all.
 

·
Registered
Joined
·
3 Posts
Just happened to me yesterday. Scares me because i cannot see all the warnings, and i've had quite a few error messages lately, but those have typically go away after turning the car off and restarting. but scary none the less.
 
1 - 20 of 56 Posts
Top