Alfa Romeo Stelvio Forum banner

41 - 56 of 56 Posts

·
Registered
Joined
·
523 Posts
Any update on why center console goes black and how to fix?
Hi there,

Since we do not like to speculate on the cause of your concerns, we kindly ask that you reach out via private messages with more details about the symptoms you've been noticing. We'd like to get a better understanding of your situation so we can better assist.

Thanks,

Courtney
Alfa Romeo Cares
 

·
Registered
Joined
·
8 Posts
This seems to be a very common issue. Unfortunately, the same thing happened to my Stelvio today (with only 12k miles), and tried the battery disconnect but did not work. Dealer is 12 days out from being able to get me in for a diagnose, also they do not provide loaner.

Very disappointed. So I guess I'll drive without the center display for a while, at least my speedo and tac still works.
 

·
Registered
Joined
·
523 Posts
This seems to be a very common issue. Unfortunately, the same thing happened to my Stelvio today (with only 12k miles), and tried the battery disconnect but did not work. Dealer is 12 days out from being able to get me in for a diagnose, also they do not provide loaner.

Very disappointed. So I guess I'll drive without the center display for a while, at least my speedo and tac still works.
Hello,

If you need any assistance while working with your dealer to get this resolved, please don't hesitate to send our team a message!

Thanks,

Courtney
Alfa Romeo Cares
 

·
Registered
2018 Alfa Romeo Stelvio
Joined
·
2 Posts
This happened to me after I got a car wash. Luckily it came back on the next day on its own. I only have 19k miles on it. I wonder if this means I should get it hand washed from now on?!
 

·
Moderator
Joined
·
458 Posts
This happened to me after I got a car wash. Luckily it came back on the next day on its own. I only have 19k miles on it. I wonder if this means I should get it hand washed from now on?!
After 33K miles and many car washes I've never had that happen to my 2019.

If that happens again to your car, whether or not after a car wash, you should get it looked at. It isn't normal.

Welcome to the forum. Tell us about your Stelvio. And we love to see photos.
 

·
Registered
2018 Alfa Romeo Stelvio
Joined
·
2 Posts
After 33K miles and many car washes I've never had that happen to my 2019.

If that happens again to your car, whether or not after a car wash, you should get it looked at. It isn't normal.

Welcome to the forum. Tell us about your Stelvio. And we love to see photos.
Yeah I definitely will if it happens again.
 

·
Registered
Alfa Romeo stelvio 2.2 diesel 210ps over 80k
Joined
·
5 Posts
So, it fixed itself today on my way to a friends to disconnect the battery as suggested above. My forward crash alert went on because a car in front of me was turning (still had plenty of time for them to turn without crashing into them, but besides the point). And next thing i know, the center display came back on! who knows. the electronics with this car are crazy
Tell me please which battery should I disconnect ? Engine or under the trunk which is actually responsible for whole electronic and tell me as well what happens with all systems after that? Should i set everything once again or it keep my changes on system? Thanks guys
 

·
Registered
Alfa Romeo stelvio 2.2 diesel 210ps over 80k
Joined
·
5 Posts
Hi, I'm sorry to hear this. Please let me know if you plan on visiting a dealership for this concern. I would be happy to open a case for you.

Alison
AlfaRomeoCares
I need assistance it happened 2nd time first after 40k 2nd now after 85k.
First issue solved itself after 24h but 2nd after 3 days nothing and still black central screen...what should I do? Disconnect battery really? If so which one ? And what happened with all security systems and my saved changes? Should i setup sth after all?
Thanks for the update
 

·
Registered
Alfa Romeo stelvio 2.2 diesel 210ps over 80k
Joined
·
5 Posts
Guys, CorgiE63, how the story with a center display has finally finished? I'm having the same issue starting yesterday. Model year 2018, as yours. Is it necessary visiting dealer? KR, Tomasz
Which battery should I disconnect? Under the trunk or in engine?and what with security systems, should I setup after all? My changes will be there or disappear? Please give me feedback soon as possible, thank you
 

·
Registered
Alfa Romeo stelvio 2.2 diesel 210ps over 80k
Joined
·
5 Posts
hey, when you said to disconnect the battery 3 times is there driving in between?

I have done it now twice and the first time the “ESC” notification was displayed and the trunk door stopped closing but would finish off locking. After the second the “ESC” went away but the trunk door still won’t work. Should I try it again for a third time or start over for the 3 tries without driving in between?
Which battery should I disconnect? Under the trunk or in engine?and what with security systems, should I setup after all? My changes will be there or disappear? Please give me feedback soon as possible, thank you
 

·
Registered
Joined
·
109 Posts
Which battery should I disconnect? Under the trunk or in engine?and what with security systems, should I setup after all? My changes will be there or disappear? Please give me feedback soon as possible, thank you
following. same issue here with a 2018 stelvio. Where is one supposed to disconnect the battery?
 

·
Registered
Joined
·
2,433 Posts
I'm confused, what battery besides the one in the trunk are you thinking to disconnect?

Where exactly is this other battery? There isn't a battery under the hood.

Disconnect it where it is, in the trunk. General rule of thumb...for pretty much anything that is powered..if disconnecting the power, do it at the source. If its under the hood, do it there. In the trunk..do it in the trunk. Simple. When you depower a remote..you just take out the batteries. Same thing with a car. Not rocket science, but does take some mechanical aptitude.

I will be frank here, there are ways just disconnecting and reconnecting a battery can screw up your electrical system.

If the question of where to disconnect a battery confuses you....probably best to just not do that yourself. You don't want to accidently short out your electrical. Not worth it, having a non-functioning screen sucks...a non functioning car though, we can probably all agree is worse.

It can happen.
 

·
Registered
Alfa Romeo stelvio 2.2 diesel 210ps over 80k
Joined
·
5 Posts
Omg hahaha thanks for your reply but You do not understand the question. It is very probably that you in USA have only one battery. My car in Europe has two batteries. Mostly stelvios have two batteries. First under the trunk and second under the hood. That's why I asked you about it. Never mind I found solution to fix it on my own and it has nothing to do with disconnect battery. It is very simple. That's all
 

·
Registered
Joined
·
46 Posts
Omg hahaha thanks for your reply but You do not understand the question. It is very probably that you in USA have only one battery. My car in Europe has two batteries. Mostly stelvios have two batteries. First under the trunk and second under the hood. That's why I asked you about it. Never mind I found solution to fix it on my own and it has nothing to do with disconnect battery. It is very simple. That's all
please post a picture of you underhood battery
 
41 - 56 of 56 Posts
Top