Alfa Romeo Stelvio Forum banner
1 - 20 of 64 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
This happens normally on cold mornings.
After a while once the engine warms up i turn the car off and back on again and it usually all clears.
Had the car from the Alfa dealer 5 months just.
Does anyone / has anyone experienced this or know what might be causing the issue.
2018 MY.

Thank you
GJ
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
Hi

yes i tried both on different occasions.
I drove for about 4 miles with the misfiring, pulled over in a garage stopped the car restarted and it was fine.
 

·
Registered
Joined
·
11 Posts
My 2018 Q4 did the same thing two different times right after startup within the first 100 meters of driving. It cleared after a restart. I changed the battery and sparkplugs. It hasn't done it since. But I think the gremlin is still there.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #12 ·
I was thinking coil packs too ! Maybe getting damp in the colder weather and the ECU shutting down that cylinder until a restart.
Ill be sure to send an update with findings.

New battery fitted about 4 weeks ago for upgraded AGM (hope its not that)

Motor vehicle Vehicle Automotive exterior Bumper Trunk


Tire Automotive tire Automotive lighting Motor vehicle Bumper
 

·
Registered
Joined
·
187 Posts
I don't know in the 4 cylinder but in the 6 cylinder that happens sometimes if you don't drive the car daily....its a PITA since then you need to go to the dealer to get the codes erased.....no DNA when that happens.....probably that has to do something with some oil leaking in a combustion chamber in the cylinder??....it can not be carbon build up.....
They redesigned the injection system last year I think.....now that wont happen. I just went today to the dealer to erase the codes.....I wish it could be retrofitted but probably that would be really costly.
When that happens I really WANT of getting rid of the car......until I accelerate in the causeway and leave everyone behind!!!......lol
 

·
Registered
Joined
·
2,766 Posts
My older quad doesn't get driven daily - and sometimes sits for weeks.
No trickle charger either.
I'd never rule out a bad battery or ibs for most anything on these, but if they are good then daily use or trickles arent necessary
 

·
Registered
2018 Alfa Romeo stelvio 2.0 Ti sport awd
Joined
·
58 Posts
Just took my car in the dealer today cause it had a engine light with the auto start stop disabled I plugged in the obdi my self it said cylinder 4 misfiring so waiting to see what’s that about since it started happing ever since 2 weeks ago when I took the car in for service to change the spark plugs serpentine belt cabin filter etc and the car only has 36K miles on it 🤦🏽‍♂️ At this point just thinking either ti sell the stelvio and lease a 2022 or a just go into a different brand
 

·
Registered
2018 Alfa Romeo stelvio 2.0 Ti sport awd
Joined
·
58 Posts
I told The service rep this today actually lol told me before I changed everything the car was fine after I changed all of that stuff I been getting misfires and engine lights for the past 2 weeks at first Bret said it was the sensor for the air filter that was loose which was bullshit but I told them this today to check the entire car to see what’s the issue they seem alittle In Competent at westbury alfa Romeo ( Long Island New York ) 🤦🏽‍♂️
 

·
Registered
Joined
·
2,863 Posts
Incompetent, and really inexperienced dealers are a real issue.

Hard to be competent when it's the first time you've encountered a problem.

Easiest way to diagnose your problem....

Code said misfire cylinder 4?

Ok, take the plug out of 4 switch it with any other cylinder, reinstall. See what happens. No need to wait for, or rely on the dealer really.
 

·
Registered
2018 Alfa Romeo stelvio 2.0 Ti sport awd
Joined
·
58 Posts
Yes code said cylinder 4 misfiring and at the same time your right it could be a simple issue or a major one but I believe it’s not since like I said it’s been happening ever since I changed the spark plugs serpentine belt cabin engine filter etc I’ll wait to see what the dealer tells me good thing is they put in a loaner so hopefully they can resolve the issue
 

·
Registered
2018 Alfa Romeo stelvio 2.0 Ti sport awd
Joined
·
58 Posts
The car already been there since the morning today so like I said Hopefully it’s a little issue and they can resolve it I was over there yelling and angry like my car been fine for 8 months ever since I got I bring it in for the scheduled services you guys recommended and spend over a 1K$ and now my car been misfiring and been in limp
Mode 3 times it’s ridiculous & on top of that they employees was reviving my car and speeding to “ test the car” cause of the exhaust I seen it on my dash cam 🤦🏽‍♂️
 
1 - 20 of 64 Posts
Top