Alfa Romeo Stelvio Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Perfect flawless performance for full year 13k miles. Last night my headlights went off for three second and came back on. Was at night at intersection. Happens twice more driving home. Headlights are set to automatic. Never any issue before. Thought a bumper could have reflected into the sensor. But not two other times while driving. Anyone else experiencing this?
 

·
Registered
Joined
·
1,269 Posts
Not positive..but pretty sure the sensor is either in the little round nub that sticks up in the center of the dash, or it is in all the mirror stuff at the windshield.

Probably the dash though since it is standard.

We're you shining any strong lights on the dash?

Otherwise take strong notes...had you just taken a bump, a turn? What about it was unique?
 

·
Registered
Joined
·
111 Posts
It may be easier to buy an inexpensive dash cam to record the problem. It could save you a lot of wasted time at the dealership.
 

·
Registered
Joined
·
117 Posts
Could be the HID bulb or control transformer. Should not be happening this soon, but could be a bad bulb. I have had bulbs go bad and take out the transformer requiring both to be replaced. (not on the Stelvio, on our other car ) Not a big fan of HID. Good light, but more complexity then needed in my opinion. Once a bulb starts to go they can act up and do just like you're describing. Hopefully the dealer has a way to check.
 
1 - 5 of 5 Posts
Top