Alfa Romeo Stelvio Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I recently purchased a 2020 Stelvio TI AWD. One of my first projects was to hardwire my Valentine One radar detector into the rearview mirror. This is something I've done with all of my previous vehicles without any issues. I used the BlendMount MirrorTap suggested for the Stelvio.

After a few hours of driving around with the MirrorTap installed, the Blind Spot System Failure light appeared on the dash. The blind spot detection still seemed to work perfectly fine, so I ignored it. Since that initial warning light, it would pop again periodically but would stay off for the most part.

After a month or so, another warning light appeared on the dash. This time it was the Front-End Collision Avoidance System failure warning light. Around the same time, all of the window switches stopped working. At this point, it seemed like my entire electrical system was failing so I took it into the dealer.

The dealer insisted that the cause of all of these issues was my radar detector being hardwired into the mirror, and made me remove the MirrorTap (they wouldn't touch it). After removing the MirrorTap, the lights stayed on, so they then reset the car and that removed the warning lights and fixed the windows.

I followed this guide when installing, which shows tapping into the blue wire. I'm wondering if anyone else has experienced these issues? Could having my radar detector hardwired really cause all of those issues? I would really really like to re-install the MirrorTap, but don't want these issues to appear again.

Thanks in advance for any help!
 

·
Registered
2021 Stelvio Ti Sport
Joined
·
419 Posts
No issues so far for over a month following the guide and tapping the blue and black wires. I did not mount my detector below the mirror, it is to the side of the whole mirror assembly. My thought is its not the tap but potentially the radar detector is messing around with the stuff that is in the mirror pod. Can you use the cigarette lighter with the V1 and see if it does the same thing. If it does I would move the V1 to the left of the pod, My R7 works fine to the left and its less conspicuous.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
No issues so far for over a month following the guide and tapping the blue and black wires. I did not mount my detector below the mirror, it is to the side of the whole mirror assembly. My thought is its not the tap but potentially the radar detector is messing around with the stuff that is in the mirror pod. Can you use the cigarette lighter with the V1 and see if it does the same thing. If it does I would move the V1 to the left of the pod, My R7 works fine to the left and its less conspicuous.
I had mine to the left of the mirror as well. I've been using the cigarette lighter after taking it to the dealer and I haven't had any issues so far.
 

·
Registered
2022 Stelvio Veloce Misano Blue Metallic/Black
Joined
·
500 Posts
I just had my R7 hardwired using a blendmount yesterday. So far so good except the clip is bent so they're sending me out a new one to replace. Sounds like a wire or a V1 issue to me.
 

·
Registered
Joined
·
180 Posts
Hi just tried to do this with a uniden hardwire kit and could not find the blue wire. I found the ground/black wire but the one next to it was blue/grey. On top of that after testing (black as ground and blue grey and all the others) with a voltage meter and the actual kit and powerep up/down cycles the same error messages came up as the OP. I did not tap into the wires and just reconnected everything but the warning same warning lights are persisting.
Will this eventually recycle through the systems and reset or so I have to go to the dealer to get the whole thing reset ?
 

·
Registered
Joined
·
5 Posts
Have there been any more adventurous souls to try this out? We just traded our 18 Ti Sport in on a 21 Ti Sport and I had the blendmount/MirrorTap/V1 combo working great before. Our 18 Stevlio didn't have the lane keep assist, or the Radar based cruise control so I came here to make sure things would wire up the same. I think I used those same Guilia forum instructions a few years ago and everything worked fine. Does anyone have any experience with the blendmount/MirrorTap integrating with all the driver assist things in their Stelvio?
 

·
Registered
Joined
·
500 Posts
This is as good a thread as others for me to ask this in since I'm getting ready to do a mirror tap for a Blackvue dashcam, but the newer units have 3 leads, GND, always on, and switched on, and I haven't been able to find a diagram or list of the wires in the camera/assist pod to tap on to.

I know from the threads that the blue wire is the switched +12, and the black wire is the ground, but I'm not seeing a reference for an always on +12
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top