Alfa Romeo Stelvio Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all,

I've a nasty problem with my 2017 Stelvio. At really slow speed approx. 3-5 mph 5-10 km/u Running at traffic jams or pulling away from zero, I am experiencing jerky upshift or gas handing , It is present at very slow speed or by pulling away from zero . It is very noticeable. My garage managed to get it a bit softer by manipulating the software. But could not tell exactly what Is going on. Anybody the same issue.

Thanks

ROn
 

·
Registered
Joined
·
14 Posts
Hi all,

I've a nasty problem with my 2017 Stelvio. At really slow speed approx. 3-5 mph 5-10 km/u Running at traffic jams or pulling away from zero, I am experiencing jerky upshift or gas handing , It is present at very slow speed or by pulling away from zero . It is very noticeable. My garage managed to get it a bit softer by manipulating the software. But could not tell exactly what Is going on. Anybody the same issue.

Thanks

ROn
I had the same thing happen to me ,
I had the car checked over . They could find nothing wrong. It’s odd after a few months of driving I haven’t noticed it at all anymore.
 

·
Registered
Joined
·
2,038 Posts
Dynamic or Normal mode. Throttle tip in is way too aggressive for traffic in d mode as turbos are spoollng up and down constantly.
 

·
Registered
Joined
·
2,804 Posts
I guess it depends on what you are coming from - there are plenty of throttle remaps like gopedal etc on the market to solve the opposite, too soft of a response.
"I haven't noticed it at all anymore"
Recalibrating your own inputs does wonders.
 
1 - 5 of 5 Posts
Top