Alfa Romeo Stelvio Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Don't get me wrong I love this car but l have been noticing some very annoying things about the alerts. Every time I get close to something when parking the park assist just beeps nonstop. Even when put into Park. Should definitely go off when in Park? Also the seat belt alarm is crazy annoying and very loud. Doesn't give you even one second to put your belt on before it goes off, I guess that's a good thing but not something I enjoy. I need like 30 seconds after I turn the car on before the seat belt alert goes crazy. Also when I use my charging cord for my phone my radio speakers crackle when streaming music. Anyone experiencing these annoyances? Are all easy fixes I think.
Any advice would be appreciated.
Thanks,
Dan
 

·
Registered
Joined
·
763 Posts
Don't get me wrong I love this car but l have been noticing some very annoying things about the alerts. Every time I get close to something when parking the park assist just beeps nonstop. Even when put into Park. Should definitely go off when in Park? Also the seat belt alarm is crazy annoying and very loud. Doesn't give you even one second to put your belt on before it goes off, I guess that's a good thing but not something I enjoy. I need like 30 seconds after I turn the car on before the seat belt alert goes crazy. Also when I use my charging cord for my phone my radio speakers crackle when streaming music. Anyone experiencing these annoyances? Are all easy fixes I think.
Any advice would be appreciated.
Thanks,
Dan
Welcome to the forum. When it comes to the beeps after in park, I have the same, but it is not every time for me. I have no idea why that is. On the seat belts, for me, I put on the belt before I push the start button. Since the seat moves forward slowly, the is no issue with it being too tight at the end of the forward movement. I have been lucky as I have not had any crackle, but I believe others have documented they have had that issue, maybe someone will chime in on that.
 

·
Registered
Joined
·
93 Posts
Welcome to the forum. When it comes to the beeps after in park, I have the same, but it is not every time for me. I have no idea why that is. On the seat belts, for me, I put on the belt before I push the start button. Since the seat moves forward slowly, the is no issue with it being too tight at the end of the forward movement. I have been lucky as I have not had any crackle, but I believe others have documented they have had that issue, maybe someone will chime in on that.
The way I view my new Alfa experience is similar to what a good friend if mine did when he was a pilot. Get in, strap in, engage engine,disable park sense until liftoff (button by headlight switch) and disable auto start/stop (the other button by headlight switch), pull onto runway (driveway) check all settings, enable park assist and blast off...I have no issue with crackle....
 

·
Registered
Joined
·
228 Posts
Park Assist Deactivation

Just deactivate the Park Sensors System by pushing the buttom located to the left of the headlight switch (upper button)(lower button is to activate/deactivate the Stop/Start System) p.138 in manual.
 

·
Read Only
Joined
·
849 Posts
I'm not 100% sure but the last firmware that I have in my car, after only 3 Maserati teams visit in Padua have the solution in it, I need to check, give me few days, I'm a little bit overcharged at work
 

·
Registered
Joined
·
3 Posts
I love this car too, but you are right. Those quirks get on my nerves sometimes. Has anyone found a solution (maybe the dealership could turn down the sensitivity) for the parking sensors? This can get quite annoying having to always turn the parking sensor off for some peace and quiet. Mine even goes off while i'm at a stop light behind another car sometimes!
 

·
Registered
Joined
·
48 Posts
You can lower Warning alarm volume in Settings

Don't get me wrong I love this car but l have been noticing some very annoying things about the alerts. Every time I get close to something when parking the park assist just beeps nonstop. Even when put into Park. Should definitely go off when in Park? Also the seat belt alarm is crazy annoying and very loud. Doesn't give you even one second to put your belt on before it goes off, I guess that's a good thing but not something I enjoy. I need like 30 seconds after I turn the car on before the seat belt alert goes crazy. Also when I use my charging cord for my phone my radio speakers crackle when streaming music. Anyone experiencing these annoyances? Are all easy fixes I think.
Any advice would be appreciated.
Thanks,
Dan
To mitigate annoyance, you can lower Warning systems alert volume in Settings. Not clear if this lowers all, but I have set this to lowest volume and have seen a difference.
 

·
Registered
Joined
·
147 Posts
I discovered that it is only the final level that keeps beeping. If you are not so close that the tone is constant, it turns off once you hit the Park button. If you are at the closest level, the alert comes on when you start the car as well.

I have taken to stopping before the alert is a constant tone, or backing off slightly - so that it is still beeping.

Hope that helps.
 

·
Registered
Joined
·
237 Posts
I have an intermittent issue with the park sensors on my '18 Ti.

I have a (small) single stall garage, and when I pull in, the park sensors just chirp at me like
crazy. I actually kind of like it because if I'm too close to one side its louder and constant.

anyway, I've had it happen a couple of times where I pull in, alarms chirping, and hit the on/off button, and
alarms KEEP ON GOING, ever after I get out, and shut the door. I've solved the problem both times by
reaching in, hitting the on/off (no break pedal, just turning on accessories), and then hitting on/off again.

I have a theory that his happens because I hit the on/off while I"m still in drive (letting the alfa put
itself in park).

Anyone else have this experience?
 

·
Registered
Joined
·
510 Posts
I have an intermittent issue with the park sensors on my '18 Ti.

I have a (small) single stall garage, and when I pull in, the park sensors just chirp at me like
crazy. I actually kind of like it because if I'm too close to one side its louder and constant.

anyway, I've had it happen a couple of times where I pull in, alarms chirping, and hit the on/off button, and
alarms KEEP ON GOING, ever after I get out, and shut the door. I've solved the problem both times by
reaching in, hitting the on/off (no break pedal, just turning on accessories), and then hitting on/off again.

I have a theory that his happens because I hit the on/off while I"m still in drive (letting the alfa put
itself in park).

Anyone else have this experience?
Hi, I'm sorry to hear this. Please let me know if you plan on visiting a dealership for this concern. I would be happy to open a case for you.

Alison
AlfaRomeoCares
 

·
Registered
Joined
·
1,797 Posts
Got rid of the auto start stop annoyance. This is the ONLY issue left and damn stupid programming to not shut off the sensors when in park. Every day I remote start car next to my fence, I come out to this stupid sound. Supposedly my vintage can't be reprogrammed. I call BS on it. Can't turn off botton remotely before some genius gives that advice AGAIN>
 
1 - 13 of 13 Posts
Top