Alfa Romeo Stelvio Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
Is anyone else experiencing a delay in changing favorite radio stations? Especially shortly after just getting into the car, I'm moving either the volume dial to the right, or hitting the "next station" button on the steering wheel, and...nothing. Takes forever for the car to catch up, and it's just another one of those Alfa Romeo frustrating quirks.

Wondering if there's a cure?
 

·
Registered
Joined
·
542 Posts
The infotainment does take a while to fully get going. I usually remote start my vehicle as I'm walking up to it. Then after getting in, strapping on my seat belt, etc enough time has passed that my phone has usually connected via bluetooth and the system is fully ready to go or close to it. The only annoying part is I can hear the stupid seatbelt chimes as I'm walking towards my car. Haha
 

·
Registered
Joined
·
1,532 Posts
Yeah...it seems to randomly be worse sometimes than others but I have noticed this too.

The other day I couldn't get sound. Not for my phone or the radio or any other source. It all showed as working and when I turned the volume knob the readout went up...but no sound. Stopped, went into the store, everything worked when I started it back up and has worked since....

...gremlins in the infotainment. As long as they stay out of the engine, transmission and AWD we are good...
 

·
Registered
Joined
·
6 Posts
Yes, I experience the same thing. It is annoying for a higher end vehicle. It is my favorites that really bug me. It always defaults back to the very 1st station when the rotary button is hit. I then have the scroll down to the station I want every time. Before the software update it would hold on to the station I was in for a few minutes before defaulting to the 1st one. This saved the hassle of always scrolling to the station you want.
 

·
Registered
Joined
·
10 Posts
Owned an Audi , replaced with the Alfa also own a Acura RDX same delays with the radio in both cars, so not only Alfa quirks . believe it's a satellite radio issue.
 
1 - 5 of 5 Posts
Top