Alfa Romeo Stelvio Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Just leased a new Stelvio. Drove it for maybe a month or so. The car already spend a week at the service dept. Currently, in for a second time in 5 weeks. Sensors are going haywire. AST Service Required, Service ESC system, Service Airbag, Parksense Unavailable Service Require, Service Hillhold Control, Service Electronic Parking Brakes, Start&Stop Unavailable, FCW Limited Functionality Front Camera Service Required. Sensors starting popping up when the car is in park and when I was driving. Mostly recently, steering wheel froze while the sensors popped up. Turned the car on and off and The steering was okay but the sensors still visible. Anyone have any thoughts.
 

·
Registered
Joined
·
426 Posts
when you suddenly get that many (unrelated) errors, it's usually caused by a bad battery / low charge.....
Try using a trickle charger.... If that helps, and you're driving enough, probably a new (AGM) battery is required
 

·
Registered
19 Quadrifoglio Trofeo White,black with green/white,Dynamic pack, Pano roof,Carbon wheel, Dark wheel
Joined
·
47 Posts
Yep and I'll go one above and make them Change the battery. Tell them you want an agm battery instead. All your problems will most likely disappear.
 

·
Registered
Joined
·
475 Posts
Just leased a new Stelvio. Drove it for maybe a month or so. The car already spend a week at the service dept. Currently, in for a second time in 5 weeks. Sensors are going haywire. AST Service Required, Service ESC system, Service Airbag, Parksense Unavailable Service Require, Service Hillhold Control, Service Electronic Parking Brakes, Start&Stop Unavailable, FCW Limited Functionality Front Camera Service Required. Sensors starting popping up when the car is in park and when I was driving. Mostly recently, steering wheel froze while the sensors popped up. Turned the car on and off and The steering was okay but the sensors still visible. Anyone have any thoughts.
Please let us know via private message if you decide to have your dealer look into this. We would like to have this documented and have a case escalated in your behalf so a Case Specialist can work with your dealer to help find a potential solution.

Alison
AlfaRomeoCares
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Please let us know via private message if you decide to have your dealer look into this. We would like to have this documented and have a case escalated in your behalf so a Case Specialist can work with your dealer to help find a potential solution.

Alison
AlfaRomeoCares
Hi Alison,

This is the second trip to the service dept in 5 weeks.I have provided them with videos of the issue as well.

Please let us know via private message if you decide to have your dealer look into this. We would like to have this documented and have a case escalated in your behalf so a Case Specialist can work with your dealer to help find a potential solution.

Alison
AlfaRomeoCares
 

·
Registered
Joined
·
475 Posts
Hi Alison,

This is the second trip to the service dept in 5 weeks.I have provided them with videos of the issue as well.
Have you had a case open for this? If not, please send us a private message. I would be happy to help!

Alison
AlfaRomeoCares
 

·
Registered
Joined
·
131 Posts
My wife’s Acura started getting electrical issues and intermittent flicker and mirror not working and immediately they tested the battery. I didn’t buy their expensive battery with no real lengthy replacement warranty. Instead picked up a champion agm from pepboys for 150 with 4 years full replacement. Battery
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
Mmmmm.... interesting. I reached out to the service dept about the AGM battery and no response as of now. In the meantime, I am going to work with AlfaRomeoCares and see what they can do. Just a shame that I leased the car on June 20th and it has spend more day in the service dept than in my driveway.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #13
Anyone used the AlfaRomeoCares service to escalate their vehicle issue? Just want to make sure it is legitimate before I give my info out. Thank you!
 

·
Registered
Joined
·
112 Posts
Definitely engage alfaromeocares
 

·
Registered
2020 Stelvio Ti Sport
Joined
·
4 Posts
.... If that helps, and you're driving enough, probably a new (AGM) battery is required
Just leased a new Stelvio. Drove it for maybe a month or so. The car already spend a week at the service dept. Currently, in for a second time in 5 weeks. Sensors are going haywire. AST Service Required, Service ESC system, Service Airbag, Parksense Unavailable Service Require, Service Hillhold Control, Service Electronic Parking Brakes, Start&Stop Unavailable, FCW Limited Functionality Front Camera Service Required. Sensors starting popping up when the car is in park and when I was driving. Mostly recently, steering wheel froze while the sensors popped up. Turned the car on and off and The steering was okay but the sensors still visible. Anyone have any thoughts.
We had the same issue with our Stelvio Ti Sport. Check out this thread: Battery. – you'll see my posts and others.

Our Stelvio is finally working as designed with the battery swapped to the Interstate AGM MTX-49 H8.

From what I can tell, the Stelvio's OEM Varta Enhanced Flooded Battery (EFB) cannot handle the electronics the Stelvio has (we use the wireless charging and Apple Car Play every trip as well) – but an Absorbent Glass Mat (AGM) battery seems to handle it better. No failures to start or any battery issues since the AGM battery replacement, and it's been a week.
 

·
Registered
Joined
·
76 Posts
We had the same issue with our Stelvio Ti Sport. Check out this thread: Battery. – you'll see my posts and others.

Our Stelvio is finally working as designed with the battery swapped to the Interstate AGM MTX-49 H8.

From what I can tell, the Stelvio's OEM Varta Enhanced Flooded Battery (EFB) cannot handle the electronics the Stelvio has (we use the wireless charging and Apple Car Play every trip as well) – but an Absorbent Glass Mat (AGM) battery seems to handle it better. No failures to start or any battery issues since the AGM battery replacement, and it's been a week.
I did the exact same thing. Same battery. And Alfa paid for it and installed it. The battery swap did not require resetting codes..
Incidently, the last time I looked at the Varta website I saw that there was a new version of the Alfa EFB battery. Why would a company produce a second version of the same battery? A problem with the original?
 
1 - 16 of 16 Posts
Top