Alfa Romeo Stelvio Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
398 Posts
Discussion Starter #1
So I downloaded the infotainment system update that was linked to on the Giulia forum. It was also mentioned in that thread that it had installed successfully on a US Giulia, and that it performed a compatibility check for your car before installing. So I did some digging through the XML file that accompanied the firmware image file, and noticed that it had a few sections for VIN number validations in the config, which gave me confidence that this was true, and that the software would refuse to install if it was not compatible.

Since I hadn't gotten any response over there, I decided to get brave and give the update a try. I had verified that the software I was running was an older release than this update was.

Old Version
20180206_213615.jpg

I plugged the USB drive in (before copying the files I formatted it FAT32 to avoid read issues) and pressed the stop/start button, but without my foot on the brake. The infotainment system immediately gave a prompt confirming I want to install the update. I thought I got a picture of that screen but apparently not.

After confirming that I wanted to install the update I got this screen about verifying the USB data which definitely put some fears at ease seeing it validate the data before installing!
20180207_230055.jpg

Verification took about 5 minutes, after which it began installing.
20180207_230357.jpg

The installation made me nervous as around 4-5% into the install I reached over and turned off the headlights which were on sucking battery with the engine off, and I was worried about encountering a low battery issue when installing. I don't know if it was related or just coincidence, but within a second of turning them off the screen went blank and stayed that way for several seconds, then the infotainment system rebooted, re-verified the USB drive was present, and re-started installing. I didn't take a picture as it wouldn't have looked any different, but it certainly made my stomach drop for a second!

Once the installation was complete I was prompted to remove the USB drive.
20180207_231643.jpg

The system rebooted the moment I pulled the drive, and took about a minute to boot up and come online, during which time a warning about audio system unavailable briefly flashed on the dash, but once it came online everything was normal.
20180207_232323.jpg

I did have to reset the 12/24 hour and my split screen settings, but otherwise nothing appeared really different. I first thought the menu system was displayed differently but I think it was just because I was used to split screen, though you can be the judge since I don't have a before & after
20180207_232026.jpg
I do feel that the bottom favorites, climate control temp, and clock settings are slightly altered with different font sizes, but certainly nothing major. Satellite radio still requires scrolling through the station list every time, settings menus all appear the same.

Conclusion? I've got none. The update doesn't appear to change anything I can tell so far, and it seems to work just fine. I can't make a case to update yours, nor can I say not to. I'm sure there are more changes I can't yet tell, but so far it seems the same as before.
 

·
Registered
Joined
·
354 Posts
So no change on the warning alarm when in Park?

I noticed once or twice, when I backed into a space, and put it in park, the alarm actually went off. So I pulled out, turned around, and parked forward one time and it worked, once. The next time I started it, the alarm would not turn off in park, so I’m back to pushing the button when required.
 

·
Registered
Joined
·
763 Posts
SailDrive, would you mind posting the two files that one should load on the flash drive for the update? I am not an expert on computers, but can follow instructions pretty good when I have details.
Thanks
 

·
Registered
Joined
·
10 Posts
Thanks for sharing. I'm assuming this would not fix the issue of the heated seats/steering wheel not coming on with the remote start when the temp is below a certain degree.

-Tarry


So I downloaded the infotainment system update that was linked to on the Giulia forum. It was also mentioned in that thread that it had installed successfully on a US Giulia, and that it performed a compatibility check for your car before installing. So I did some digging through the XML file that accompanied the firmware image file, and noticed that it had a few sections for VIN number validations in the config, which gave me confidence that this was true, and that the software would refuse to install if it was not compatible.

Since I hadn't gotten any response over there, I decided to get brave and give the update a try. I had verified that the software I was running was an older release than this update was.

Old Version
View attachment 3809

I plugged the USB drive in (before copying the files I formatted it FAT32 to avoid read issues) and pressed the stop/start button, but without my foot on the brake. The infotainment system immediately gave a prompt confirming I want to install the update. I thought I got a picture of that screen but apparently not.

After confirming that I wanted to install the update I got this screen about verifying the USB data which definitely put some fears at ease seeing it validate the data before installing!
View attachment 3817

Verification took about 5 minutes, after which it began installing.
View attachment 3825

The installation made me nervous as around 4-5% into the install I reached over and turned off the headlights which were on sucking battery with the engine off, and I was worried about encountering a low battery issue when installing. I don't know if it was related or just coincidence, but within a second of turning them off the screen went blank and stayed that way for several seconds, then the infotainment system rebooted, re-verified the USB drive was present, and re-started installing. I didn't take a picture as it wouldn't have looked any different, but it certainly made my stomach drop for a second!

Once the installation was complete I was prompted to remove the USB drive.
View attachment 3833

The system rebooted the moment I pulled the drive, and took about a minute to boot up and come online, during which time a warning about audio system unavailable briefly flashed on the dash, but once it came online everything was normal.
View attachment 3857

I did have to reset the 12/24 hour and my split screen settings, but otherwise nothing appeared really different. I first thought the menu system was displayed differently but I think it was just because I was used to split screen, though you can be the judge since I don't have a before & after
View attachment 3841
I do feel that the bottom favorites, climate control temp, and clock settings are slightly altered with different font sizes, but certainly nothing major. Satellite radio still requires scrolling through the station list every time, settings menus all appear the same.

Conclusion? I've got none. The update doesn't appear to change anything I can tell so far, and it seems to work just fine. I can't make a case to update yours, nor can I say not to. I'm sure there are more changes I can't yet tell, but so far it seems the same as before.
 

·
Premium Member
Joined
·
398 Posts
Discussion Starter #5
So no change on the warning alarm when in Park?

I noticed once or twice, when I backed into a space, and put it in park, the alarm actually went off. So I pulled out, turned around, and parked forward one time and it worked, once. The next time I started it, the alarm would not turn off in park, so I’m back to pushing the button when required.
I had a sense this morning that it was slightly less sensitive in park, but no they are definitely still on. It's hard to tell since I was moving the things in front of the car last night when installing the projector lights, so it wasn't 100% the objects in the exact same position as it has been.

SailDrive, would you mind posting the two files that one should load on the flash drive for the update? I am not an expert on computers, but can follow instructions pretty good when I have details.
Thanks
Nope, won't take responsibility for posting a link to files which I understand are supposed to be restricted to dealers only, but you are certainly free to follow the link to the other thread I included and get them there! :grin The download is a zip file, you only need extract the two files and copy them to a blank FAT32 formatted USB drive.

Thanks for sharing. I'm assuming this would not fix the issue of the heated seats/steering wheel not coming on with the remote start when the temp is below a certain degree.

-Tarry
That was my #1 hope, and a big NOPE! :crying

to be honest, I can't really tell anything different in the update except the version number. Over on the Guilia forum people were saying that the update fixes audio quality problems when playing over USB. That's the only semi confirmed change I know of.
 

·
Registered
Joined
·
763 Posts
I had a sense this morning that it was slightly less sensitive in park, but no they are definitely still on. It's hard to tell since I was moving the things in front of the car last night when installing the projector lights, so it wasn't 100% the objects in the exact same position as it has been.



Nope, won't take responsibility for posting a link to files which I understand are supposed to be restricted to dealers only, but you are certainly free to follow the link to the other thread I included and get them there! :grin The download is a zip file, you only need extract the two files and copy them to a blank FAT32 formatted USB drive.



That was my #1 hope, and a big NOPE! :crying

to be honest, I can't really tell anything different in the update except the version number. Over on the Guilia forum people were saying that the update fixes audio quality problems when playing over USB. That's the only semi confirmed change I know of.
Totally understand, thanks for the info
 

·
Registered
Joined
·
1 Posts
It seems like Alfa has shut down unauthorized downloads of the updated Infotainment software. Can anyone PM or provide me the zip file so I can try to update my system? Pretty please and thank you.
 

·
Registered
Joined
·
1 Posts
Hi Mulanzo, I also have to upgrade my FW, did you get the file already? If so would you mind to share with me? Thanks.
 
1 - 8 of 8 Posts
Top