Alfa Romeo Stelvio Forum banner

1 - 20 of 72 Posts

·
Registered
Joined
·
138 Posts
15K miles. I have had BIG issues - it all turned out to be related to an incorrectly fitted pre-heater (diesel not petrol version installed by dealer...). Caused the limp-home mode to engage. After having this fixed, no issues whatsoever and I am VERY happy with the car.
 

·
Registered
Joined
·
33 Posts
6 months, 15k miles and the only problem I have is the radio reboots about once a month, probably some SiriusXM update I assume.
 

·
Registered
Joined
·
13 Posts
6 months, 5,500 miles with zero issues...other than quickly wearing out tires, and my cheeks hurting from so much grinning.

Its a fantastic car and I'm sure I'll experience some issues along the way, just like every...other...European...performance...car...I've...owned. Its the price we pay for owning vehicles engineered for performance and thrills vs. reliability and sedately getting from point a to b.
 

·
Registered
Joined
·
1,409 Posts
12,000 miles of driving the best SUV ever....that does not drive like an SUV. Just had the usual updates done as needed and an outside temp sensor replaced which is now dead accurate.
 

·
Registered
Joined
·
310 Posts
13 months and I love it

The couple recalls and only 1 check engine light that was part of a software update

LOVE it and look forward to it every time I grab the keys to take it out
 

·
Registered
Joined
·
68 Posts
1500 miles and trans leaks led to needing a new tranny and just got back after 3 weeks with a fxxking mini van and now it’s looking like braking failure. Also says service brake pads. After 1700 miles??? I am certain I have a lemon 🍋
 

·
Registered
Joined
·
211 Posts
MY2018, build date Oct2017, purchased on 31Mar2018. Only problem I've had was at month 13 after SiriusXM subscription renewed, that's when I started having the radio reboots and intermittant popping sounds from driver side tweeter. Went in for software update and recently did SiriusXM signal refresh, which seems to have solved problem. I listen to SiriusXM alot.
 

·
Registered
Joined
·
29 Posts
!0,000 mile service this week. No significant problems, just the winter tire graunching and a couple of odd things with the entertainment system. Hopefully, software update fixed all that. Need new tires, though.
 

·
Registered
Joined
·
19 Posts
18Mths old, 12,000km. The servicing and all the recalls were done on purchasing three months ago, from the main dealer in Calgary, AB. Had the throttle warning pop on with the check engine light (solid yellow). Apparently this is a sensor on the engine and replacement of neg battery lead. Waited two weeks for the parts to come in and had to chase this. Then another 2 week wait for a service appointment and to get a loaner as apparently they need it for 2 days!!.


I am trying hard to be patient and realistic with Edmonton, Alfa, especially as the guys there do appear to be doing the best they can, with a dealership that appears to be ran by a completely incompetent owner. These delays really would not be acceptable elsewhere. My last three vehicles, Lexus, Audi and Infiniti, never had anything but fantastic and immediate service at a quarter of the cost. Quote for a basic oil change only, nothing else, $430 CAN, 4 times the cost of any of these other dealers. Struggling to see how they can justify it frankly, and its spoiling the experience as I love the car.
 

·
Registered
Joined
·
220 Posts
5k Miles with no major issues after 8 months. I had the first service completed recently with oil change and tire rotation. I broke the visor clip and replaced it myself costed 20 bucks. I had a flat tire from a nail which I had plugged so that was only 20. The vehicle is very reliable and I am happy with it.
 

·
Registered
Joined
·
508 Posts
We should have a parallel thread called "Stelvio WITH Problems" and see how that fares!

Anyway, my leased days of driving with a prayer and swearing at the infotainment system are almost over. Looking to lease the Volvo XC40 next.
 
1 - 20 of 72 Posts
Top