Alfa Romeo Stelvio Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
In the last 2 weeks I had to reset the sunroof twice. I don't use it often (too hot in Miami right now!) let's say once-twice a week in the evening... sometimes less. Since I got the car i probably fully openened it 20-25 times max. however, in the last two weeks when closing it I heard a different noise... that happened twice. When trying to open it afterwards - either straight after the noise or the following morning - the buttons didn't work. nothing happened to both the mesh and the sunroof. I checked on the roof and everything looked normal. I had to perform the reset and once the mesh fully opened and the sunroof opened and closed post reset everything was working again. just weird that I had this happening to me twice in a week so wondering if it happened to anyone else? thanks
 

·
Registered
Joined
·
574 Posts
In the last 2 weeks I had to reset the sunroof twice. I don't use it often (too hot in Miami right now!) let's say once-twice a week in the evening... sometimes less. Since I got the car i probably fully openened it 20-25 times max. however, in the last two weeks when closing it I heard a different noise... that happened twice. When trying to open it afterwards - either straight after the noise or the following morning - the buttons didn't work. nothing happened to both the mesh and the sunroof. I checked on the roof and everything looked normal. I had to perform the reset and once the mesh fully opened and the sunroof opened and closed post reset everything was working again. just weird that I had this happening to me twice in a week so wondering if it happened to anyone else? thanks
Hi marcoc,

I certainly understand why this would be concerning. If this continues to happen, I recommend having your Stelvio diagnosed by your local Alfa Romeo dealer as they are in the best position to assist. Our team is available via PM if you are in need of any assistance with that process.

Mark
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
6 Posts
Sunroof Issue

My sunroof does not work properly, the screen switch does not work and the only way to open the sunroof is put the glass switch to the CLOSED position, but the glass opens only halfway before closing again. I will try the reset.
 

·
Registered
Joined
·
574 Posts
My sunroof does not work properly, the screen switch does not work and the only way to open the sunroof is put the glass switch to the CLOSED position, but the glass opens only halfway before closing again. I will try the reset.
Sorry to hear of the concern you’re experiencing with your sunroof, taosgreg. I recommend having this diagnosed by your local Alfa Romeo dealer if you have not done so already. We’re just a PM away if you need any assistance during that process.

Mark
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
1 Posts
In the last 2 weeks I had to reset the sunroof twice. I don't use it often (too hot in Miami right now!) let's say once-twice a week in the evening... sometimes less. Since I got the car i probably fully openened it 20-25 times max. however, in the last two weeks when closing it I heard a different noise... that happened twice. When trying to open it afterwards - either straight after the noise or the following morning - the buttons didn't work. nothing happened to both the mesh and the sunroof. I checked on the roof and everything looked normal. I had to perform the reset and once the mesh fully opened and the sunroof opened and closed post reset everything was working again. just weird that I had this happening to me twice in a week so wondering if it happened to anyone else? thanks
I have had this issue with my Stelvio since I owned my Stelvio and have had Alfa Romeo technicians look at it. They fix it and I have the same problem again. I have to manually reset it all the time. Very frustrating.
 

·
Registered
Joined
·
1 Posts
In the last 2 weeks I had to reset the sunroof twice. I don't use it often (too hot in Miami right now!) let's say once-twice a week in the evening... sometimes less. Since I got the car i probably fully openened it 20-25 times max. however, in the last two weeks when closing it I heard a different noise... that happened twice. When trying to open it afterwards - either straight after the noise or the following morning - the buttons didn't work. nothing happened to both the mesh and the sunroof. I checked on the roof and everything looked normal. I had to perform the reset and once the mesh fully opened and the sunroof opened and closed post reset everything was working again. just weird that I had this happening to me twice in a week so wondering if it happened to anyone else? thanks

Can you please explain how to reset? I have the same problem
 

·
Registered
Joined
·
187 Posts
In the last 2 weeks I had to reset the sunroof twice. I don't use it often (too hot in Miami right now!) let's say once-twice a week in the evening... sometimes less. Since I got the car i probably fully openened it 20-25 times max. however, in the last two weeks when closing it I heard a different noise... that happened twice. When trying to open it afterwards - either straight after the noise or the following morning - the buttons didn't work. nothing happened to both the mesh and the sunroof. I checked on the roof and everything looked normal. I had to perform the reset and once the mesh fully opened and the sunroof opened and closed post reset everything was working again. just weird that I had this happening to me twice in a week so wondering if it happened to anyone else? thanks
where did you take the car to get it serviced?....they take forever at The Collection....
 
1 - 7 of 7 Posts
Top