Alfa Romeo Stelvio Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Anyone have trouble with the sunshade buttons? Mine just stopped working normally... only if I press the two close buttons together the shade will start moving, otherwise nothing. Seems to me some wires crossed somewhere, somehow. Any advice? I can't seem to get through to my dealer's service, so I thought I'd try here.
 

·
Registered
Joined
·
32 Posts
I've tried initialization procedure, but my sunshade button still not working. The only way I can open the sunshade is to hit the sunroof open button...
 

·
Registered
Joined
·
536 Posts
coincidentally mine is now doing that, did the initialization procedure without success.

My sunroof will not open unless I press once and then press again, at which time the sunshade moves all the way closed, full cycles open and then the sunroof opens.



I've tried initialization procedure, but my sunshade button still not working. The only way I can open the sunshade is to hit the sunroof open button...
 

·
Registered
Joined
·
32 Posts
Does anyone have any advice on the sunshade "open" button not working? Since the initialization process didn't work, I'm out of ideas...At some point, I'll take it into the dealer and let you know what I learn. Thanks
 

·
Registered
Joined
·
510 Posts
Does anyone have any advice on the sunshade "open" button not working? Since the initialization process didn't work, I'm out of ideas...At some point, I'll take it into the dealer and let you know what I learn. Thanks
Keep us all updated on your dealer visit, ArturoPo10. Our team is available via direct message if you need any assistance with the servicing process.

Jasmine
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
536 Posts
we;re in the same boat, now to open my sunroof I have to do the initialization process which hold the sunroof button down )(to close)it cycles thru the sunshade coming all the way forward, release the button, the press same button down again, sunshade opens and then when sunshad all the way back the sunroof goes thru open cycle. I note the open sunroof part of the button does not work, the sunshad but doesn't work in open/close and the "vent sunroof" in front of those two buttons doesn't work (I think at some point I hit that button and it messed the whole process up. INitializatrion process doesn't work. Not due for service for 8 months or so but when I take it to the dealer for the recalls I'll let them look at it, they're 150 miles away.


Does anyone have any advice on the sunshade "open" button not working? Since the initialization process didn't work, I'm out of ideas...At some point, I'll take it into the dealer and let you know what I learn. Thanks
 

·
Registered
Joined
·
510 Posts
we;re in the same boat, now to open my sunroof I have to do the initialization process which hold the sunroof button down )(to close)it cycles thru the sunshade coming all the way forward, release the button, the press same button down again, sunshade opens and then when sunshad all the way back the sunroof goes thru open cycle. I note the open sunroof part of the button does not work, the sunshad but doesn't work in open/close and the "vent sunroof" in front of those two buttons doesn't work (I think at some point I hit that button and it messed the whole process up. INitializatrion process doesn't work. Not due for service for 8 months or so but when I take it to the dealer for the recalls I'll let them look at it, they're 150 miles away.
Hi zvezdah1,
We understand how this could be frustrating and would like to offer our assistance when you visit your dealer. If this is something that interests you, please send us a private message with additional information.
Julie
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
4 Posts
A little off point but is there a way to “vent” tilt up sunroof (not open, or move back) and keep the sunscreen closed?
In previous cars I could. So far havent found a way.......
 

·
Registered
Joined
·
536 Posts
it does have a vent button (in front of the sunshade and power roof buttons) according to the manual the sunshade has to be open
 

·
Registered
Joined
·
11 Posts
Yep I have the same problem just started yesterday. Sunroof has been working but now won't budge.

I tried initiation process. I hear a clunking when pressing the close sunroof button. Then release and hold the same button, then wait, then wait, finger to sore to hold, release

Am I missing something? This is with the engine running right??

NOTHING - attempted several times and gave up. Dealer too far away.

At leaset its stuck in the closed position
 

·
Registered
Joined
·
536 Posts
this seems to be common issue now. I also tried the initialization process multiple times without success. What I have found at least for me, if you hold the button down, release and hold the button down again, it cycles both sunshade and sunroof. so if the sunshade is closed it will cycle all the way open, and when it reaches that point if you keep pressing the sunroof button it will fully cycle the sunroof from closed to fully open, release the button and it will stay open, to close you have to hold the sunroof button down again.

I'm afraid to do it tho it might get stuck in the open position, dealer is 150 miles away so won't be doing anything with it til the recall letter.

Yep I have the same problem just started yesterday. Sunroof has been working but now won't budge.

I tried initiation process. I hear a clunking when pressing the close sunroof button. Then release and hold the same button, then wait, then wait, finger to sore to hold, release

Am I missing something? This is with the engine running right??

NOTHING - attempted several times and gave up. Dealer too far away.

At leaset its stuck in the closed position
 

·
Registered
Joined
·
11 Posts
Chis are you doing that with the engine running? I've tried both start settings but nothing will move including the shade.

Like you I'm going to wait because it looks like there are already two recalls for this vehicle so a visit to the dealer is in my future

I just know if I mess with it I'll end up with the roof stuck open.

I did call Alfa Romeo but the rep I got didn't have a clue about it and said no-one else had the issue
 

·
Registered
Joined
·
536 Posts
I've pm'd alfa cares on this forum just to give them a heads up that a number of people at least on this forum are having problems almost certainly we're not the only ones. I'm suspicious that the problem started after I pressed the power sunroof vent button (buttion in front of sunroof/sunshade buttons) prior to that I had no issues.

Yes I am doing with motor running as per the manual that states press start button to AVV mode


Chis are you doing that with the engine running? I've tried both start settings but nothing will move including the shade.

Like you I'm going to wait because it looks like there are already two recalls for this vehicle so a visit to the dealer is in my future

I just know if I mess with it I'll end up with the roof stuck open.

I did call Alfa Romeo but the rep I got didn't have a clue about it and said no-one else had the issue
 

·
Registered
Joined
·
536 Posts
OK, I revisited the initialization procedure and it fixed the issue, not sure what I had been doing wrong but step by step this is what I did.

WIth engine on,
1,press the sunroof close button and hold down until the sunroof and shade cycle fully closed.
2. turn the ignition off, wait at least ten seconds.
3. turn the ignition on (engine running)
4.Press the sunroof close button and hold down at least ten seconds you should then hear a clunk, release the button.
5.Within 5 seconds press the sunroof close button and hold down, it will go thru the full opening cycle for both sunshade and sunroof.
6. It should perform normally now. It worked the first time I did it today. Now both sunroof and sunshade open / close works as it should.
 

·
Registered
Joined
·
510 Posts
Yep I have the same problem just started yesterday. Sunroof has been working but now won't budge.

I tried initiation process. I hear a clunking when pressing the close sunroof button. Then release and hold the same button, then wait, then wait, finger to sore to hold, release

Am I missing something? This is with the engine running right??

NOTHING - attempted several times and gave up. Dealer too far away.

At leaset its stuck in the closed position
Hi InkPump,

Thank you for sharing your experience. If you are continuing to have this concern with your sunroof, we recommend taking your vehicle to the dealer. Please message us with your VIN and mileage so that we can document this concern on your behalf.

Darlene
Alfa Romeo Care Specialist
 

·
Registered
Joined
·
1,797 Posts
I was waiting for when I got time but my 2 hitlist issues are first, the thermometer is WAY off and doesn't correct even on long runs (5-10 degrees). Secondly, my sunroof has just gone berserk and will not operate. It is closed and I will leave it that way. Positioning of those buttons and the illegible hyro glyphics don't help. At first it kept closing and popping open but now it won't work at all. Hardly ever open them anyway and would be happy if only the sunshade worked.
 

·
Registered
Joined
·
536 Posts
I finally sorted mine as posted above by doing the initialization process several times until I stumbled on the correct way to do it, the manual is a bit confusing on how to do this.


These are the step by step instructions that worked for me:

WIth engine on,
1,press the sunroof close button and hold down until the sunroof and shade cycle fully closed.
2. turn the ignition off, wait at least ten seconds.
3. turn the ignition on (engine running)
4.Press the sunroof close button and hold down at least ten seconds you should then hear a clunk, release the button.
5.Within 5 seconds press the sunroof close button and hold down, it will go thru the full opening cycle for both sunshade and sunroof.
6. It should perform normally now. It worked the first time I did it today. Now both sunroof and sunshade open / close works as it should.

I was waiting for when I got time but my 2 hitlist issues are first, the thermometer is WAY off and doesn't correct even on long runs (5-10 degrees). Secondly, my sunroof has just gone berserk and will not operate. It is closed and I will leave it that way. Positioning of those buttons and the illegible hyro glyphics don't help. At first it kept closing and popping open but now it won't work at all. Hardly ever open them anyway and would be happy if only the sunshade worked.
 
1 - 20 of 32 Posts
Top