Alfa Romeo Stelvio Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Does anyone know how to access the Trip B display? I looked in all the manuals but couldn’t find it. Trip A is easy to access, but it’s getting to Trip B that I can’t figure out.
 

·
Registered
Joined
·
478 Posts
Settings menu under cluster. Switch it on from there and it should show up.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
Thank you, but I’m not sure where you are referring to. The end of the wiper stalk brings up Trip A only.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #6
Finally figured it out. Talk about unintuitive.
 

·
Registered
Joined
·
197 Posts
i'm reactivating this thread rather than start a new one.

I had something "quirky" to report. I have an '18 Stelvio Ti.

I returned from a road trip on Sunday. Pulled the car into the garade, and just pulled it out for a
errand (3 days later). I noticed at the first stop light that both my A and B trip odometers had been
reset to zero. I reset trip A when I fill up, and I leave trip B as a running tab. In fact, trip B had 5000
miles on it, and the only reason it didn't have more, is because the same thing happened 5000 miles
ago when both Trip A and B reset. I've had no battery issues...the car started fine. I didn't accidentally reset
A and B at a refueling because I came right home after the trip and tank was 1/2 full.

Has anyone seen this? Any ideas?

Thanks
 

·
Registered
Joined
·
197 Posts
And it did it again...just hopped in the stelvio for an errand, and it both A and B odometer reset themsevles 56 miles ago...I know there was at least 200-300 miles on both of them when I last the vehicle.
 
1 - 8 of 8 Posts
Top