Alfa Romeo Stelvio Forum banner

41 - 52 of 52 Posts

·
Registered
Joined
·
122 Posts
Another forum member suggested putting some washers under the front seat rails to raise it up.
I've been waiting for it to warm up to give it a try...but for me (6'2") I think 1/4-1/2" lift sounds about right.
 

·
Registered
Joined
·
8 Posts
I have the Ti sport and the seats are not very good if you drive more than 3 hours, this isnt something you would notice on a test drive. I know I didnt. I would have bought the Porsche if I had known it would be like this.
Not sure what exactly makes them uncomfortable after a long drive, I think the bottom cushion is too short, or the bottom doesnt tilt back far enough. Ive got a 89 Jeep and though the support is terrible, i dont hurt after a long drive like I do in the Alfa. Its probably just my old butt thats the problem.
I'd say that how the seat feels after sitting in it for a prolonged period of time may just depend on the person... I drive the Ti-Sport trim and love them but I did however come from a Subaru WRX STi which did not have anything near the support or quality of the Alfa Ti Sport seats. I drove from STL to CHI couple weeks ago and my ass never once got numb hahaha but I do only weigh 175 lbs...
 

·
Registered
Joined
·
39 Posts
Happy to hear you were able to get an appointment scheduled, 108. Please keep us updated on how it goes.

Kate
AlfaRomeoCares
I completed the software update today. About a 1 hour wait. Dave Smith Alfa Romeo/Maserati has developed a stand-alone service center that makes for a comfortable visit and singular focus on the brand. I'm all caught up with my 1 year service and this recall.
 

·
Registered
Joined
·
39 Posts
I am in Florida. Downloaded the Alfa romeo owner app. Tried to register an account. It said a link would be sent. Never showed up. Deleted the app
I've had the same problem with the Alfa Romeo app. I called Alfa Cares and was advised to first sign up on Mopar.com then download the app and sign up on the App with the Mopar.com credentials. Like you, I never get the setup email the site says will be sent. Tried multiple times and have advised Alfa Cares. They said that the problem would be escalated, but I never was contacted. At least I know know it's not just me.
 

·
Registered
Joined
·
4 Posts
Please see attached. Most, if not all, vehicles within the years specified are included. I can check your VIN if desired but you will receive physical mail most likely if your VIN is included.
@20k service today, recall getting done as well.
 

·
Registered
Joined
·
1 Posts
Hi All,

FYI. Just had all 3 recalls (V27, V84,& W05) and complementary first oil change (thanks Alfa USA!) done at my local dealership yesterday. It could just be me, but I do notice the after-run pump\whining noise is now running much longer (more than 3 minutes) after the engine shutdown. Hope the W05 recall won't accelerate the demise of the still healthy factory battery in my car.

One a side note... During the service, I asked the Service Advisor to take a look at the fading paint on one of the front brake calipers. The paint is so faded as if there is no clear coat on that caliper at all. However, the advisor doesn't believe it will be cover by the factory warranty and asked me to contact Alfa directly. Do a lot of you guys have the same fading caliper paint issue as well? I have attached some pictures of the Good and Bad caliper for comparison.


Thank you!

Albert
late 2018 Stelvio Ti Sport

Please see attached. Most, if not all, vehicles within the years specified are included. I can check your VIN if desired but you will receive physical mail most likely if your VIN is included.
 

Attachments

·
Registered
Joined
·
228 Posts
AlAlfa,
I have a MY2018/build date Oct17 Stromboli gray Stelvio with black calipers but no fading issues. Sorry to hear you are having an issue. I agree it looks like the clear coat may not have been applied properly to protect the paint.
 

·
Registered
Joined
·
416 Posts
I've had the same problem with the Alfa Romeo app. I called Alfa Cares and was advised to first sign up on Mopar.com then download the app and sign up on the App with the Mopar.com credentials. Like you, I never get the setup email the site says will be sent. Tried multiple times and have advised Alfa Cares. They said that the problem would be escalated, but I never was contacted. At least I know know it's not just me.
Hi 108,
Sorry to hear about the trouble you're having. I would like to look into this further on our end to see if you had a previous case open for this concern why you this was not resolved for you. Please send us a private message with your VIN.

@20k service today, recall getting done as well.
We hope you're appointment went well, WAdbb. We're glad to see you had this recall completed. Please let us know if you have any questions or concerns.

Lydia
AlfaRomeoCares
 

·
Registered
Joined
·
10 Posts
Had the W05 recall done today as well as the newest infotainment software updated. The My Alfa Romeo app already updated to show the recall was performed.
 

·
Registered
Joined
·
5 Posts
Ok...had the recall done today.
I noticed the buzzing sound that is present when you shut off the vehicle and is suppose to be the pump for the turbo cooler or something like that.
Before the recall it would stay on maybe 30 seconds or so then shut off. I drove the stelvio to work tonight and was getting on it pretty good, opening it up stop light to stop light. This is about a 20 min drive. When I got to work and shut it off that buzzing sound lasted for over 5 minutes. I had to walk away and couldn't wait any longer for it to stop. I went back to it about 20 min later to make sure it turned off and it did. That's a big difference in turning off time from 30 sec to 1 min....to now 5 + minutes. I hope it was that long for the way I was driving and not going to be the norm.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #51
Ok...had the recall done today.
I noticed the buzzing sound that is present when you shut off the vehicle and is suppose to be the pump for the turbo cooler or something like that.
Before the recall it would stay on maybe 30 seconds or so then shut off. I drove the stelvio to work tonight and was getting on it pretty good, opening it up stop light to stop light. This is about a 20 min drive. When I got to work and shut it off that buzzing sound lasted for over 5 minutes. I had to walk away and couldn't wait any longer for it to stop. I went back to it about 20 min later to make sure it turned off and it did. That's a big difference in turning off time from 30 sec to 1 min....to now 5 + minutes. I hope it was that long for the way I was driving and not going to be the norm.
Yeah, it isn't a fixed time. If you park the car hot, it will take a long time to get it cooled down. Just drive gently the last couple miles of the trip.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #52
To those that have had the recall. please correct me if its not extending the fan timer.
The electric cooling fan does respond to the PCM indeed, so there is a chance that this was changed/lengthened, but this is not the focus of the recall. Not 100% sure on that
 
41 - 52 of 52 Posts
Top